SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Database)  >   MySQL Vendors:   MySQL.com, Oracle
(Ubuntu Issues Fix) MySQL Multiple Bugs Let Remote Users Access and Modify Data, Remote and Local Users Deny Service, and Local Users Gain Elevated Privileges
SecurityTracker Alert ID:  1033972
SecurityTracker URL:  http://securitytracker.com/id/1033972
CVE Reference:   CVE-2015-4730, CVE-2015-4766, CVE-2015-4792, CVE-2015-4800, CVE-2015-4802, CVE-2015-4815, CVE-2015-4816, CVE-2015-4819, CVE-2015-4826, CVE-2015-4830, CVE-2015-4833, CVE-2015-4836, CVE-2015-4858, CVE-2015-4861, CVE-2015-4862, CVE-2015-4864, CVE-2015-4866, CVE-2015-4870, CVE-2015-4879, CVE-2015-4890, CVE-2015-4895, CVE-2015-4904, CVE-2015-4910, CVE-2015-4913   (Links to External Site)
Date:  Oct 27 2015
Impact:   Denial of service via local system, Denial of service via network, Disclosure of system information, Disclosure of user information, Modification of system information, Modification of user information, User access via local system
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 5.5.44 and prior, 5.6.25 and prior
Description:   Multiple vulnerabilities were reported in MySQL. A remote user can access and modify data on the target system. A remote or local user can cause denial of service conditions on the target system. A local user can obtain elevated privileges on the target system.

A local user can exploit a flaw in the Client programs component to gain elevated privileges [CVE-2015-4819].

A remote authenticated user can exploit a flaw in the Server DML component to partially access data, partially modify data, and partially deny service [CVE-2015-4879].

A remote authenticated user can exploit a flaw in the Server DDL component to cause partial denial of service conditions [CVE-2015-4815, CVE-2015-4858, CVE-2015-4862, CVE-2015-4905, CVE-2015-4913].

A remote authenticated user can exploit a flaw in the Server InnoDB component to cause partial denial of service conditions [CVE-2015-4816, CVE-2015-4861, CVE-2015-4866, CVE-2015-4895].

A remote authenticated user can exploit a flaw in the Server Optimizer component to cause partial denial of service conditions [CVE-2015-4800].

A remote authenticated user can exploit a flaw in the Server Parser component to cause partial denial of service conditions [CVE-2015-4870].

A remote authenticated user can exploit a flaw in the Server Partition component to cause partial denial of service conditions [CVE-2015-4802, CVE-2015-4833].

A remote authenticated user can exploit a flaw in the Server Security Privileges component to partially modify data [CVE-2015-4830].

A remote authenticated user can exploit a flaw in the Server Types component to cause partial denial of service conditions [CVE-2015-4730].

A remote authenticated user can exploit a flaw in the Server Types component to partially access data [CVE-2015-4826].

A remote authenticated user can exploit a flaw in the libmysqld component to cause partial denial of service conditions [CVE-2015-4904].

A remote authenticated user can exploit a flaw in the Server Query Cache component to cause partial denial of service conditions [CVE-2015-4807].

A remote authenticated user can exploit a flaw in the Server Replication component to cause partial denial of service conditions [CVE-2015-4890].

A remote authenticated user can exploit a flaw in the Server Security Privileges component to cause partial denial of service conditions [CVE-2015-4791].

A remote authenticated user can exploit a flaw in the Server Security Privileges component to partially modify data [CVE-2015-4864].

A remote user can exploit a flaw in the Server SP component to cause partial denial of service conditions [CVE-2015-4836].

A remote authenticated user can exploit a flaw in the Server Memcached component to cause partial denial of service conditions [CVE-2015-4910].

A local user can exploit a flaw in the Server Security Firewall component to cause partial denial of service conditions [CVE-2015-4766].

A remote user can exploit a flaw in the Server Partition component to cause partial denial of service conditions [CVE-2015-4792].

The following researchers reported these and other Oracle product vulnerabilities:

Aaron Portnoy of Exodus Intelligence; Adam Gowdiak of Security Explorations; Adam Willard of Foreground Security; Advanced Threat Research Team, Intel Security; Aleksandr Dubinsky of SyncWords; Alexey Tyurin of ERPScan; Andrea Palazzo of Truel IT; Behzad Najjarpour Jabbari of Secunia Research; Borked of the Google Security Team; Brooks Li of Trend Micro; Cihan Oncu of Biznet Bilisim A.S.;
Colm O hEigeartaigh; Dan Peled; David Byrne of Trustwave SpiderLabs; David Litchfield of Google; Egor Karbutov of ERPScan; Erlend Oftedal; FortiGuard Labs of Fortinet, Inc.; Francis Provencher from COSIG; Francois Goichon of Context Information Security; G. Geshev from MWR Labs; Gregory Golds; Guido Vranken; Ivan Chalykin of ERPScan; Jacob Smith; Jakub Palaczynski from ING Services Polska;
Jeff Kayser of Jibe Consulting; Kana Toko; Khai Tran of Netspi; Leopold von Niebelschuetz-Godlewski of Trustwave; Marcin Gebarowski; Nikita Kelesis of ERPScan; Osanda Malith Jayathissa; Oscar Andersson; Red Hat Product Security; Sergey Gorbaty of Salesforce.com; Travis Emmert of Salesforce.com; and Ugur Cihan Koc of Avea Iletisim Hizmetleri A.S.

Impact:   A remote user can obtain data on the target system.

A remote user can modify data on the target system.

A local user can cause denial of service conditions on the target system.

A remote user can cause denial of service conditions.

A local user can obtain elevated privileges on the target system.

Solution:   Ubuntu has issued a fix for CVE-2015-4730, CVE-2015-4766, CVE-2015-4792, CVE-2015-4800, CVE-2015-4802, CVE-2015-4815, CVE-2015-4816, CVE-2015-4819, CVE-2015-4826, CVE-2015-4830, CVE-2015-4833, CVE-2015-4836, CVE-2015-4858, CVE-2015-4861, CVE-2015-4862, CVE-2015-4864, CVE-2015-4866, CVE-2015-4870, CVE-2015-4879, CVE-2015-4890, CVE-2015-4895, CVE-2015-4904, CVE-2015-4910, and CVE-2015-4913.

The Ubuntu advisory is available at:

http://www.ubuntu.com/usn/usn-2781-1

Vendor URL:  www.ubuntu.com/usn/usn-2781-1 (Links to External Site)
Cause:   Access control error
Underlying OS:  Linux (Ubuntu)
Underlying OS Comments:  12.04 LTS, 14.04 LTS, 14.10, 15.04

Message History:   This archive entry is a follow-up to the message listed below.
Oct 20 2015 MySQL Multiple Bugs Let Remote Users Access and Modify Data, Remote and Local Users Deny Service, and Local Users Gain Elevated Privileges



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC