SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   VMware vCenter Vendors:   VMware
VMware vCenter Bugs Let Remote Users Deny Service and Execute Arbitrary Code
SecurityTracker Alert ID:  1033720
SecurityTracker URL:  http://securitytracker.com/id/1033720
CVE Reference:   CVE-2015-1047, CVE-2015-2342   (Links to External Site)
Updated:  Apr 28 2016
Original Entry Date:  Oct 1 2015
Impact:   Denial of service via network, Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 5.0 prior to 5.u update u3e, 5.1 prior to 5.1 update u3b, 5.5 prior to 5.5 update 3, 6.0 prior to 6.0.0b
Description:   Several vulnerabilities were reported in VMware vCenter. A remote user can cause denial of service conditions. A remote user can execute arbitrary code on the target system.

The vpxd service does not properly validate long heartbeat messages. A remote user can send specially crafted data to cause denial of service conditions on the target vpxd service [CVE-2015-1047].

The Google Security Team reported this vulnerability.

The JMX RMI service is not properly configured [CVE-2015-2342]. A remote user can connect to the service and may be able to invoke the service to execute arbitrary code on the target system.

[Editor's note: The appliance versions of the software (e.g., 5.1 and after) are not affected by the JMX RMI vulnerability because the vulnerable service port is blocked.]

The original advisory is available at:

https://www.7elements.co.uk/resources/technical-advisories/cve-2015-2342-vmware-vcenter-remote-code-execution/

Doug McLeod of 7 Elements Ltd (via HP's Zero Day Initiative) reported this vulnerability.

Impact:   A remote user can cause denial of service conditions on the target vpxd service.

A remote user can execute arbitrary code on the target system.

Solution:   The vendor has issued a fix (5.0u3e, 5.1u3b, 5.5u3, 6.0.0b).

[Editor's note: On February 12, 2016, the vendor updated their advisory to indicate that an additional patch is required for vCenter Server 5.0 U3e, 5.1 U3b, and 5.5 U3/U3a/U3b running on Windows in order to correct CVE-2015-2342. On April 27, 2016, the vendor updated their advisory to indicate that no additional patch is necessary for version 5.5 U3d on Windows].

The vendor's advisory is available at:

http://www.vmware.com/security/advisories/VMSA-2015-0007.html

Vendor URL:  www.vmware.com/security/advisories/VMSA-2015-0007.html (Links to External Site)
Cause:   Access control error, Input validation error

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC