SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   VMware ESXi Vendors:   VMware
VMware ESXi Double Free Memory Error in OpenSLP SLPDProcessMessage() Lets Remote Users Execute Arbitrary Code on the Target System
SecurityTracker Alert ID:  1033719
SecurityTracker URL:  http://securitytracker.com/id/1033719
CVE Reference:   CVE-2015-5177   (Links to External Site)
Updated:  Aug 7 2018
Original Entry Date:  Oct 1 2015
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): ESXi 5.0, 5.1, 5.5
Description:   A vulnerability was reported in VMware ESXi. A remote user can execute arbitrary code on the target system.

A remote user can send specially crafted data to trigger a double-free memory error in the OpenSLP SLPDProcessMessage() function and execute arbitrary code on the target system.

Qinghao Tang of QIHU 360 reported this vulnerability.

Impact:   A remote user can execute arbitrary code on the target system.
Solution:   The vendor has issued a fix.

6.7: ESXi670-201806401-BG
6.5: ESXi650-201806401-BG
6.0: ESXi600-201806401-BG
5.5: ESXi550-201509101
5.1: ESXi510-201510101
5.0: ESXi500-201510101

[Editor's note: On October 7, 2015, the vendor updated their advisory to indicate that a non-security issue exists in ESXi 5.5 U3 and is corrected in ESXi 5.5 U3a.]

The vendor's advisory is available at:

http://www.vmware.com/security/advisories/VMSA-2015-0007.html

Vendor URL:  www.vmware.com/security/advisories/VMSA-2015-0007.html (Links to External Site)
Cause:   Access control error

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC