SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Apache Subversion Vendors:   Apache Software Foundation, subversion.tigris.org
(Oracle Issues Fix for Oracle Linux) Apache Subversion Bugs Let Remote Users Obtain Potentially Sensitive Information
SecurityTracker Alert ID:  1033313
SecurityTracker URL:  http://securitytracker.com/id/1033313
CVE Reference:   CVE-2015-3187   (Links to External Site)
Date:  Aug 18 2015
Impact:   Disclosure of system information, Disclosure of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 1.7.0 to 1.7.20, 1.8.0 to 1.8.13
Description:   Two vulnerabilities were reported in Apache Subversion. A remote user can obtain potentially sensitive information on the target system.

A remote user can supply a specially crafted path value to exploit a flaw in mod_authz_svn to gain access to potentially sensitive information from an ostensibly hidden repository [CVE-2015-3184].

Repositories configured for anonymous read are affected.

[Editor's note: This vulnerability has been assigned CVE-2015-3185 for the Apache httpd.]

A remote authenticated user can exploit a flaw in svn_repos_trace_node_locations() to view path names that are ostensibly hidden by authz [CVE-2015-3187].

C. Michael Pilato of CollabNet reported these vulnerabilities.

Impact:   A remote user can obtain potentially sensitive information from an ostensibly hidden repository.

A remote authenticated user can view ostensibly hidden path names.

Solution:   Oracle has issued a fix for CVE-2015-3187.

The Oracle Linux advisory is available at:

http://linux.oracle.com/errata/ELSA-2015-1633.html

Vendor URL:  linux.oracle.com/errata/ELSA-2015-1633.html (Links to External Site)
Cause:   Access control error
Underlying OS:  Linux (Oracle)
Underlying OS Comments:  6

Message History:   This archive entry is a follow-up to the message listed below.
Aug 7 2015 Apache Subversion Bugs Let Remote Users Obtain Potentially Sensitive Information



 Source Message Contents

Subject:  [El-errata] ELSA-2015-1633 Moderate: Oracle Linux 6 subversion security update

Oracle Linux Security Advisory ELSA-2015-1633

http://linux.oracle.com/errata/ELSA-2015-1633.html

The following updated rpms for Oracle Linux 6 have been uploaded to the 
Unbreakable Linux Network:

i386:
mod_dav_svn-1.6.11-15.el6_7.i686.rpm
subversion-1.6.11-15.el6_7.i686.rpm
subversion-devel-1.6.11-15.el6_7.i686.rpm
subversion-gnome-1.6.11-15.el6_7.i686.rpm
subversion-javahl-1.6.11-15.el6_7.i686.rpm
subversion-kde-1.6.11-15.el6_7.i686.rpm
subversion-perl-1.6.11-15.el6_7.i686.rpm
subversion-ruby-1.6.11-15.el6_7.i686.rpm
subversion-svn2cl-1.6.11-15.el6_7.noarch.rpm

x86_64:
mod_dav_svn-1.6.11-15.el6_7.x86_64.rpm
subversion-1.6.11-15.el6_7.i686.rpm
subversion-1.6.11-15.el6_7.x86_64.rpm
subversion-devel-1.6.11-15.el6_7.i686.rpm
subversion-devel-1.6.11-15.el6_7.x86_64.rpm
subversion-gnome-1.6.11-15.el6_7.i686.rpm
subversion-gnome-1.6.11-15.el6_7.x86_64.rpm
subversion-javahl-1.6.11-15.el6_7.i686.rpm
subversion-javahl-1.6.11-15.el6_7.x86_64.rpm
subversion-kde-1.6.11-15.el6_7.i686.rpm
subversion-kde-1.6.11-15.el6_7.x86_64.rpm
subversion-perl-1.6.11-15.el6_7.i686.rpm
subversion-perl-1.6.11-15.el6_7.x86_64.rpm
subversion-ruby-1.6.11-15.el6_7.i686.rpm
subversion-ruby-1.6.11-15.el6_7.x86_64.rpm
subversion-svn2cl-1.6.11-15.el6_7.noarch.rpm

SRPMS:
http://oss.oracle.com/ol6/SRPMS-updates/subversion-1.6.11-15.el6_7.src.rpm



Description of changes:

[1.6.11-15]
- add security fixes for CVE-2015-0248, CVE-2015-0251, CVE-2015-3187


_______________________________________________
El-errata mailing list
El-errata@oss.oracle.com
https://oss.oracle.com/mailman/listinfo/el-errata
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC