SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (VPN)  >   OpenSSH Vendors:   OpenSSH.org
(Ubuntu Issues Fix) OpenSSH PAM Privilege Separation Bugs Lets Remote Users Gain Elevated Privileges in Certain Cases
SecurityTracker Alert ID:  1033289
SecurityTracker URL:  http://securitytracker.com/id/1033289
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  Aug 14 2015
Impact:   User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 6.9p1 and prior
Description:   Two vulnerabilities were reported in OpenSSH. A remote user can gain elevated privileges in certain cases.

A remote user that can exploit a separate vulnerability in the unprivileged pre-authentication process to execute arbitrary code can then exploit two separate flaws in sshd(8) to bypass privilege separation controls [CVE-2015-6563, CVE-2015-6564].

Moritz Jodeit of Blue Frost Security GmbH reported these vulnerabilities.

Impact:   A remote user that can exploit an independent vulnerability in the pre-authentication process can bypass the privilege separation controls.
Solution:   Ubuntu has issued a fix.

The Ubuntu advisory is available at:

http://www.ubuntu.com/usn/usn-2710-1

Vendor URL:  www.ubuntu.com/usn/usn-2710-1 (Links to External Site)
Cause:   Access control error
Underlying OS:  Linux (Ubuntu)
Underlying OS Comments:  12.04 LTS, 14.04 LTS, 15.04

Message History:   This archive entry is a follow-up to the message listed below.
Aug 14 2015 OpenSSH PAM Privilege Separation Bugs Lets Remote Users Gain Elevated Privileges in Certain Cases



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC