SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Device (Intrusion Detection)  >   IBM Security Network IPS Vendors:   IBM
(IBM Issues Fix for IBM Security Network IPS) Red Hat OpenSSL Locking Error in ssleay_rand_bytes() Lets Remote Users Deny Service
SecurityTracker Alert ID:  1033194
SecurityTracker URL:  http://securitytracker.com/id/1033194
CVE Reference:   CVE-2015-3216   (Links to External Site)
Date:  Aug 6 2015
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 4.3, 4.4, 4.5, 4.6, 4.6.1, 4.6.2
Description:   A vulnerability was reported in OpenSSL on Red Hat. A remote user can cause denial of service conditions on the target system. IBM Security Network IPS is affected.

A remote user can send specially crafted data to a target multi-threaded application that uses OpenSSL to trigger an out-of-bounds memory read error in ssleay_rand_bytes() and cause the application to crash.

Johannes Bauer reported this vulnerability.

Impact:   A remote user can cause the target application to crash.
Solution:   IBM has issued a fix for IBM Security Network IPS.

The IBM advisory is available at:

https://www-304.ibm.com/support/docview.wss?uid=swg21962039

Vendor URL:  www-304.ibm.com/support/docview.wss?uid=swg21962039 (Links to External Site)
Cause:   Access control error

Message History:   This archive entry is a follow-up to the message listed below.
Jun 16 2015 Red Hat OpenSSL Locking Error in ssleay_rand_bytes() Lets Remote Users Deny Service



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2020, SecurityGlobal.net LLC