SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (VPN)  >   GnuTLS Vendors:   gnutls.org
(Oracle Issues Fix for Oracle Linux) GnuTLS Certificate Validation Flaw Lets Remote Users Force a Signature Algorithm Downgrade
SecurityTracker Alert ID:  1033114
SecurityTracker URL:  http://securitytracker.com/id/1033114
CVE Reference:   CVE-2015-0282   (Links to External Site)
Date:  Jul 29 2015
Impact:   Modification of system information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 3.1.0
Description:   A vulnerability was reported in GnuTLS. A remote user can force the use of a weaker signature algorithm.

The software does not verify that the RSA PKCS #1 signature algorithm matches the signature algorithm specified in the certificate. A remote user can exploit this to force the use of a weaker encryption algorithm.

Impact:   A remote user can force the use of a weaker signature algorithm.
Solution:   Oracle has issued a fix.

The Oracle advisory is available at:

http://linux.oracle.com/errata/ELSA-2015-1457.html

Vendor URL:  linux.oracle.com/errata/ELSA-2015-1457.html (Links to External Site)
Cause:   Authentication error
Underlying OS:  Linux (Oracle)
Underlying OS Comments:  6

Message History:   This archive entry is a follow-up to the message listed below.
Apr 17 2015 GnuTLS Certificate Validation Flaw Lets Remote Users Force a Signature Algorithm Downgrade



 Source Message Contents

Subject:  [El-errata] ELSA-2015-1457 Moderate: Oracle Linux 6 gnutls security and bug fix update

Oracle Linux Security Advisory ELSA-2015-1457

http://linux.oracle.com/errata/ELSA-2015-1457.html

The following updated rpms for Oracle Linux 6 have been uploaded to the 
Unbreakable Linux Network:

i386:
gnutls-2.8.5-18.el6.i686.rpm
gnutls-devel-2.8.5-18.el6.i686.rpm
gnutls-guile-2.8.5-18.el6.i686.rpm
gnutls-utils-2.8.5-18.el6.i686.rpm

x86_64:
gnutls-2.8.5-18.el6.i686.rpm
gnutls-2.8.5-18.el6.x86_64.rpm
gnutls-devel-2.8.5-18.el6.i686.rpm
gnutls-devel-2.8.5-18.el6.x86_64.rpm
gnutls-guile-2.8.5-18.el6.i686.rpm
gnutls-guile-2.8.5-18.el6.x86_64.rpm
gnutls-utils-2.8.5-18.el6.x86_64.rpm

SRPMS:
http://oss.oracle.com/ol6/SRPMS-updates/gnutls-2.8.5-18.el6.src.rpm



Description of changes:

[2.8.5-18]
- fix CVE-2015-0282 (#1198159)
- fix CVE-2015-0294 (#1198159)

[2.8.5-17]
- Corrected value initialization in mpi printing (#1129241)

[2.8.5-16]
- Check for expiry information in the CA certificates (#1159778)

[2.8.5-15]
- fix issue with integer padding in certificates and keys (#1036385)


_______________________________________________
El-errata mailing list
El-errata@oss.oracle.com
https://oss.oracle.com/mailman/listinfo/el-errata
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC