SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (VPN)  >   GnuTLS Vendors:   gnutls.org
(Red Hat Issues Fix) GnuTLS Certificate Validation Flaw Lets Remote Users Force a Signature Algorithm Downgrade
SecurityTracker Alert ID:  1033058
SecurityTracker URL:  http://securitytracker.com/id/1033058
CVE Reference:   CVE-2015-0282   (Links to External Site)
Date:  Jul 24 2015
Impact:   Modification of system information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 3.1.0
Description:   A vulnerability was reported in GnuTLS. A remote user can force the use of a weaker signature algorithm.

The software does not verify that the RSA PKCS #1 signature algorithm matches the signature algorithm specified in the certificate. A remote user can exploit this to force the use of a weaker encryption algorithm.

Impact:   A remote user can force the use of a weaker signature algorithm.
Solution:   Red Hat has issued a fix.

The Red Hat advisory is available at:

https://rhn.redhat.com/errata/RHSA-2015-1457.html

Vendor URL:  rhn.redhat.com/errata/RHSA-2015-1457.html (Links to External Site)
Cause:   Authentication error
Underlying OS:  Linux (Red Hat Enterprise)
Underlying OS Comments:  6

Message History:   This archive entry is a follow-up to the message listed below.
Apr 17 2015 GnuTLS Certificate Validation Flaw Lets Remote Users Force a Signature Algorithm Downgrade



 Source Message Contents

Subject:  [RHSA-2015:1457-01] Moderate: gnutls security and bug fix update

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Moderate: gnutls security and bug fix update
Advisory ID:       RHSA-2015:1457-01
Product:           Red Hat Enterprise Linux
Advisory URL:      https://rhn.redhat.com/errata/RHSA-2015-1457.html
Issue date:        2015-07-22
Updated on:        2015-01-15
CVE Names:         CVE-2014-8155 CVE-2015-0282 CVE-2015-0294 
=====================================================================

1. Summary:

Updated gnutls packages that fix three security issues and one bug are now
available for Red Hat Enterprise Linux 6.

Red Hat Product Security has rated this update as having Moderate security
impact. Common Vulnerability Scoring System (CVSS) base scores, which give
detailed severity ratings, are available for each vulnerability from the
CVE links in the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux Desktop (v. 6) - i386, x86_64
Red Hat Enterprise Linux Desktop Optional (v. 6) - i386, x86_64
Red Hat Enterprise Linux HPC Node (v. 6) - x86_64
Red Hat Enterprise Linux HPC Node Optional (v. 6) - x86_64
Red Hat Enterprise Linux Server (v. 6) - i386, ppc64, s390x, x86_64
Red Hat Enterprise Linux Server Optional (v. 6) - i386, ppc64, s390x, x86_64
Red Hat Enterprise Linux Workstation (v. 6) - i386, x86_64
Red Hat Enterprise Linux Workstation Optional (v. 6) - i386, x86_64

3. Description:

The GnuTLS library provides support for cryptographic algorithms and for
protocols such as Transport Layer Security (TLS).

It was found that GnuTLS did not check activation and expiration dates of
CA certificates. This could cause an application using GnuTLS to
incorrectly accept a certificate as valid when its issuing CA is already
expired. (CVE-2014-8155)

It was found that GnuTLS did not verify whether a hashing algorithm listed
in a signature matched the hashing algorithm listed in the certificate.
An attacker could create a certificate that used a different hashing
algorithm than it claimed, possibly causing GnuTLS to use an insecure,
disallowed hashing algorithm during certificate verification.
(CVE-2015-0282)

It was discovered that GnuTLS did not check if all sections of X.509
certificates indicate the same signature algorithm. This flaw, in
combination with a different flaw, could possibly lead to a bypass of the
certificate signature check. (CVE-2015-0294)

The CVE-2014-8155 issue was discovered by Marcel Kolaja of Red Hat.
The CVE-2015-0282 and CVE-2015-0294 issues were discovered by Nikos
Mavrogiannopoulos of the Red Hat Security Technologies Team.

This update also fixes the following bug:

* Previously, under certain circumstances, the certtool utility could
generate X.509 certificates which contained a negative modulus.
Consequently, such certificates could have interoperation problems with the
software using them. The bug has been fixed, and certtool no longer
generates X.509 certificates containing a negative modulus. (BZ#1036385)

Users of gnutls are advised to upgrade to these updated packages, which
contain backported patches to correct these issues.

4. Solution:

Before applying this update, make sure all previously released errata 
relevant to your system have been applied.

For details on how to apply this update, refer to:

https://access.redhat.com/articles/11258

5. Bugs fixed (https://bugzilla.redhat.com/):

1036385 - Certtool generates x509 certificates which contain negative modulus
1194371 - CVE-2015-0282 gnutls: RSA PKCS#1 signature verification forgery
1196323 - CVE-2015-0294 gnutls: certificate algorithm consistency checking issue
1197995 - CVE-2014-8155 gnutls: gnutls does not perform date/time checks on CA certificates

6. Package List:

Red Hat Enterprise Linux Desktop (v. 6):

Source:
gnutls-2.8.5-18.el6.src.rpm

i386:
gnutls-2.8.5-18.el6.i686.rpm
gnutls-debuginfo-2.8.5-18.el6.i686.rpm
gnutls-utils-2.8.5-18.el6.i686.rpm

x86_64:
gnutls-2.8.5-18.el6.i686.rpm
gnutls-2.8.5-18.el6.x86_64.rpm
gnutls-debuginfo-2.8.5-18.el6.i686.rpm
gnutls-debuginfo-2.8.5-18.el6.x86_64.rpm
gnutls-utils-2.8.5-18.el6.x86_64.rpm

Red Hat Enterprise Linux Desktop Optional (v. 6):

i386:
gnutls-debuginfo-2.8.5-18.el6.i686.rpm
gnutls-devel-2.8.5-18.el6.i686.rpm
gnutls-guile-2.8.5-18.el6.i686.rpm

x86_64:
gnutls-debuginfo-2.8.5-18.el6.i686.rpm
gnutls-debuginfo-2.8.5-18.el6.x86_64.rpm
gnutls-devel-2.8.5-18.el6.i686.rpm
gnutls-devel-2.8.5-18.el6.x86_64.rpm
gnutls-guile-2.8.5-18.el6.i686.rpm
gnutls-guile-2.8.5-18.el6.x86_64.rpm

Red Hat Enterprise Linux HPC Node (v. 6):

Source:
gnutls-2.8.5-18.el6.src.rpm

x86_64:
gnutls-2.8.5-18.el6.i686.rpm
gnutls-2.8.5-18.el6.x86_64.rpm
gnutls-debuginfo-2.8.5-18.el6.i686.rpm
gnutls-debuginfo-2.8.5-18.el6.x86_64.rpm
gnutls-utils-2.8.5-18.el6.x86_64.rpm

Red Hat Enterprise Linux HPC Node Optional (v. 6):

x86_64:
gnutls-debuginfo-2.8.5-18.el6.i686.rpm
gnutls-debuginfo-2.8.5-18.el6.x86_64.rpm
gnutls-devel-2.8.5-18.el6.i686.rpm
gnutls-devel-2.8.5-18.el6.x86_64.rpm
gnutls-guile-2.8.5-18.el6.i686.rpm
gnutls-guile-2.8.5-18.el6.x86_64.rpm

Red Hat Enterprise Linux Server (v. 6):

Source:
gnutls-2.8.5-18.el6.src.rpm

i386:
gnutls-2.8.5-18.el6.i686.rpm
gnutls-debuginfo-2.8.5-18.el6.i686.rpm
gnutls-devel-2.8.5-18.el6.i686.rpm
gnutls-utils-2.8.5-18.el6.i686.rpm

ppc64:
gnutls-2.8.5-18.el6.ppc.rpm
gnutls-2.8.5-18.el6.ppc64.rpm
gnutls-debuginfo-2.8.5-18.el6.ppc.rpm
gnutls-debuginfo-2.8.5-18.el6.ppc64.rpm
gnutls-devel-2.8.5-18.el6.ppc.rpm
gnutls-devel-2.8.5-18.el6.ppc64.rpm
gnutls-utils-2.8.5-18.el6.ppc64.rpm

s390x:
gnutls-2.8.5-18.el6.s390.rpm
gnutls-2.8.5-18.el6.s390x.rpm
gnutls-debuginfo-2.8.5-18.el6.s390.rpm
gnutls-debuginfo-2.8.5-18.el6.s390x.rpm
gnutls-devel-2.8.5-18.el6.s390.rpm
gnutls-devel-2.8.5-18.el6.s390x.rpm
gnutls-utils-2.8.5-18.el6.s390x.rpm

x86_64:
gnutls-2.8.5-18.el6.i686.rpm
gnutls-2.8.5-18.el6.x86_64.rpm
gnutls-debuginfo-2.8.5-18.el6.i686.rpm
gnutls-debuginfo-2.8.5-18.el6.x86_64.rpm
gnutls-devel-2.8.5-18.el6.i686.rpm
gnutls-devel-2.8.5-18.el6.x86_64.rpm
gnutls-utils-2.8.5-18.el6.x86_64.rpm

Red Hat Enterprise Linux Server Optional (v. 6):

i386:
gnutls-debuginfo-2.8.5-18.el6.i686.rpm
gnutls-guile-2.8.5-18.el6.i686.rpm

ppc64:
gnutls-debuginfo-2.8.5-18.el6.ppc.rpm
gnutls-debuginfo-2.8.5-18.el6.ppc64.rpm
gnutls-guile-2.8.5-18.el6.ppc.rpm
gnutls-guile-2.8.5-18.el6.ppc64.rpm

s390x:
gnutls-debuginfo-2.8.5-18.el6.s390.rpm
gnutls-debuginfo-2.8.5-18.el6.s390x.rpm
gnutls-guile-2.8.5-18.el6.s390.rpm
gnutls-guile-2.8.5-18.el6.s390x.rpm

x86_64:
gnutls-debuginfo-2.8.5-18.el6.i686.rpm
gnutls-debuginfo-2.8.5-18.el6.x86_64.rpm
gnutls-guile-2.8.5-18.el6.i686.rpm
gnutls-guile-2.8.5-18.el6.x86_64.rpm

Red Hat Enterprise Linux Workstation (v. 6):

Source:
gnutls-2.8.5-18.el6.src.rpm

i386:
gnutls-2.8.5-18.el6.i686.rpm
gnutls-debuginfo-2.8.5-18.el6.i686.rpm
gnutls-devel-2.8.5-18.el6.i686.rpm
gnutls-utils-2.8.5-18.el6.i686.rpm

x86_64:
gnutls-2.8.5-18.el6.i686.rpm
gnutls-2.8.5-18.el6.x86_64.rpm
gnutls-debuginfo-2.8.5-18.el6.i686.rpm
gnutls-debuginfo-2.8.5-18.el6.x86_64.rpm
gnutls-devel-2.8.5-18.el6.i686.rpm
gnutls-devel-2.8.5-18.el6.x86_64.rpm
gnutls-utils-2.8.5-18.el6.x86_64.rpm

Red Hat Enterprise Linux Workstation Optional (v. 6):

i386:
gnutls-debuginfo-2.8.5-18.el6.i686.rpm
gnutls-guile-2.8.5-18.el6.i686.rpm

x86_64:
gnutls-debuginfo-2.8.5-18.el6.i686.rpm
gnutls-debuginfo-2.8.5-18.el6.x86_64.rpm
gnutls-guile-2.8.5-18.el6.i686.rpm
gnutls-guile-2.8.5-18.el6.x86_64.rpm

These packages are GPG signed by Red Hat for security.  Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2014-8155
https://access.redhat.com/security/cve/CVE-2015-0282
https://access.redhat.com/security/cve/CVE-2015-0294
https://access.redhat.com/security/updates/classification/#moderate

8. Contact:

The Red Hat security contact is <secalert@redhat.com>. More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2015 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iD8DBQFVrzeUXlSAg2UNWIIRAvGyAJ4ihCbJNrh2OQApebjpshHi1oJOSgCfZVpE
V1GWk9rJwamgNOvnvQYWIfY=
=ENJ7
-----END PGP SIGNATURE-----


-- 
Enterprise-watch-list mailing list
Enterprise-watch-list@redhat.com
https://www.redhat.com/mailman/listinfo/enterprise-watch-list
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC