SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Microsoft .NET Vendors:   Microsoft
Microsoft .NET Bugs Let Remote Users Gain Elevated Privileges and Deny Service
SecurityTracker Alert ID:  1032297
SecurityTracker URL:  http://securitytracker.com/id/1032297
CVE Reference:   CVE-2015-1672, CVE-2015-1673   (Links to External Site)
Date:  May 12 2015
Impact:   Denial of service via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 1.1 SP1, 2.0 SP2, 3.5, 3.5.1, 4.0, 4.5, 4.5.1, 4.5.2
Description:   Two vulnerabilities were reported in Microsoft .NET. A remote user can obtain elevated privileges on the target system. A remote user can cause denial of service conditions on the target system.

A remote user can send specially crafted XML data to a target .NET application to trigger a recursion and cause excessive resource consumption on the target system [CVE-2015-1672].

John Heasman of DocuSign reported this vulnerability.

The .NET Windows Forms (WinForms) libraries do not properly handle objects in memory. A remote user can create a specially crafted partial trust application that, when installed by the target user, will execute arbitrary code on the target system [CVE-2015-1673].

Kalle Niemitalo reported this vulnerability.

Impact:   A remote user can cause denial of service conditions.

A remote user can obtain elevated privileges on the target system.

Solution:   The vendor has issued a fix.

A patch matrix is available in the vendor's advisory.

The Microsoft advisory is available at:

https://technet.microsoft.com/library/security/ms15-048

Vendor URL:  technet.microsoft.com/library/security/ms15-048 (Links to External Site)
Cause:   Input validation error, Resource error
Underlying OS:  Windows (2003), Windows (2008), Windows (2012), Windows (7), Windows (8), Windows (Vista)
Underlying OS Comments:  2003 SP2, Vista SP2, 2008 SP2, 7 SP1, 2008 R2 SP1, 8, 8.1, 2012, 2012 R2, RT, RT 8.1; and prior service packs

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC