SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   HPE OneView (Insight Control) Vendors:   HPE
(HP Issues Fix for HP Insight Control) Glibc Buffer Overflow in __nss_hostname_digits_dots() Lets Remote and Local Users Execute Arbitrary Code
SecurityTracker Alert ID:  1032273
SecurityTracker URL:  http://securitytracker.com/id/1032273
CVE Reference:   CVE-2015-0235   (Links to External Site)
Updated:  May 29 2015
Original Entry Date:  May 7 2015
Impact:   Execution of arbitrary code via local system, Execution of arbitrary code via network, User access via local system, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   A vulnerability was reported in Glibc. A remote user can execute arbitrary code on the target system. A local user can obtain elevated privileges on the target system. HP Insight Control is affected.

A remote or local user can send specially crafted data to trigger a buffer overflow in __nss_hostname_digits_dots() and execute arbitrary code on the target system. The code will run with the privileges of the target application or service using the glibc library.

The buffer overflow can be accessed via the various gethostbyname() functions.

Several Linux-based applications that use glibc are affected.

Qualys reported this vulnerability.

Impact:   A remote user can execute arbitrary code on the target system.

A local user can obtain elevated privileges on the target system.

Solution:   HP has issued a fix for HP Insight Control for Linux.

The HP advisory is available at:

http://h20564.www2.hp.com/hpsc/doc/public/display?docId=emr_na-c04655384

HP has also issued a fix for HP Insight Control server deployment.

The HP advisory is available at:

http://h20564.www2.hp.com/hpsc/doc/public/display?docId=emr_na-c04655364

HP has also issued a fix for HP Insight Control server provisioning.

The HP advisory is available at:

http://h20564.www2.hp.com/hpsc/doc/public/display?docId=emr_na-c04647400

Vendor URL:  www.gnu.org/software/libc/ (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Any)

Message History:   This archive entry is a follow-up to the message listed below.
Jan 27 2015 Glibc Buffer Overflow in __nss_hostname_digits_dots() Lets Remote and Local Users Execute Arbitrary Code



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2020, SecurityGlobal.net LLC