SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Security)  >   FreeRADIUS Vendors:   FreeRADIUS Server Project
FreeRADIUS EAP-PWD Module Bugs Let Remote Users Deny Service
SecurityTracker Alert ID:  1032266
SecurityTracker URL:  http://securitytracker.com/id/1032266
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  May 6 2015
Impact:   Denial of service via network, Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 3.0 to 3.0.8
Description:   Several vulnerabilities were reported in FreeRADIUS. A remote user can cause denial of service conditions on the target system. The impact of other vulnerabilities was not specified.

A remote user can send a specially crafted EAP-PWD packet to trigger a null pointer dereference and cause the target service to crash.

A remote user can send a specially crafted EAP-PWD packet to trigger a read overflow.

A remote user can send specially crafted data to trigger a one-byte buffer overflow on the target system.

The EAP-PWD module is not enabled by default.

Jouni Malinen reported these vulnerabilities.

Impact:   A remote user can cause denial of service conditions.

The impact of some of the vulnerabilities was not specified.

Solution:   The vendor has issued a fix (3.0.8).

The vendor's advisory is available at:

http://freeradius.org/security.html

Vendor URL:  freeradius.org/security.html (Links to External Site)
Cause:   Boundary error, Input validation error
Underlying OS:  Linux (Any), UNIX (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC