SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Dnsmasq Vendors:   Kelley, Simon
Dnsmasq Flaw in setup_reply() Lets Remote Users Deny Service
SecurityTracker Alert ID:  1032195
SecurityTracker URL:  http://securitytracker.com/id/1032195
CVE Reference:   CVE-2015-3294   (Links to External Site)
Date:  Apr 24 2015
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  Exploit Included:  Yes  
Version(s): 2.72
Description:   A vulnerability was reported in Dnsmasq. A remote user can cause denial of service conditions on the target system.

A remote user can send a specially crafted DNS request packet to read portions of the process memory and cause the target service to crash.

The original advisory is available at:

http://lists.thekelleys.org.uk/pipermail/dnsmasq-discuss/2015q2/009382.html

Nick Sampanis reported this vulnerability.

Impact:   A remote user can cause the target service to crash.
Solution:   The vendor has issued a fix (2.73rc4).

The vendor has also issued a source code fix, available at:

http://thekelleys.org.uk/gitweb/?p=dnsmasq.git;a=commit;h=ad4a8ff7d9097008d7623df8543df435bfddeac8

Vendor URL:  www.thekelleys.org.uk/dnsmasq/doc.html (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Any), UNIX (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
May 5 2015 (Ubuntu Issues Fix) Dnsmasq Flaw in setup_reply() Lets Remote Users Deny Service
Ubuntu has issued a fix for Ubuntu 12.04 LTS, 14.04 LTS, 14.10, and 15.04.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2020, SecurityGlobal.net LLC