SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Database)  >   MySQL Vendors:   MySQL.com, Oracle
MySQL Multiple Bugs Let Remote Users Deny Service, Remote Authenticated Users Partially Access and Modify Data, and Local Users Partially Modify Data on the Target System
SecurityTracker Alert ID:  1032121
SecurityTracker URL:  http://securitytracker.com/id/1032121
CVE Reference:   CVE-2015-0405, CVE-2015-0423, CVE-2015-0433, CVE-2015-0438, CVE-2015-0439, CVE-2015-0441, CVE-2015-0498, CVE-2015-0499, CVE-2015-0500, CVE-2015-0501, CVE-2015-0503, CVE-2015-0505, CVE-2015-0506, CVE-2015-0507, CVE-2015-0508, CVE-2015-0511, CVE-2015-2566, CVE-2015-2567, CVE-2015-2568, CVE-2015-2571, CVE-2015-2573, CVE-2015-2575, CVE-2015-2576   (Links to External Site)
Date:  Apr 14 2015
Impact:   Denial of service via network, Disclosure of system information, Disclosure of user information, Modification of system information, Modification of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 5.1.34, 5.5.42, 5.6.23
Description:   Multiple vulnerabilities were reported in MySQL. A remote user can cause denial of service conditions on the target system. A remote authenticated user can partially access and modify data on the target system. A local user can partially modify data on the target system.

A remote user can exploit a flaw in the MySQL Server Compiling component to cause denial of service conditions [CVE-2015-0501].

A remote user can exploit a flaw in the MySQL Server Privileges component to cause partial denial of service conditions [CVE-2015-2568].

A remote authenticated user can exploit a flaw in the MySQL Connectors Connector/J component to partially access and partially modify data [CVE-2015-2575].

A remote authenticated user can exploit a flaw in the MySQL Server DDL component to cause partial denial of service conditions [CVE-2015-2573].

A remote authenticated user can exploit a flaw in the MySQL Server Information Schema component to cause partial denial of service conditions [CVE-2015-0500].

A remote authenticated user can exploit a flaw in the MySQL Server InnoDB component to cause partial denial of service conditions [CVE-2015-0439].

A remote authenticated user can exploit a flaw in the MySQL Server InnoDB component to cause partial denial of service conditions [CVE-2015-0508].

A remote authenticated user can exploit a flaw in the MySQL Server InnoDB DML component to cause partial denial of service conditions [CVE-2015-0433].

A remote authenticated user can exploit a flaw in the MySQL Server Optimizer component to cause partial denial of service conditions [CVE-2015-0423].

A remote authenticated user can exploit a flaw in the MySQL Server Optimizer component to cause partial denial of service conditions [CVE-2015-2571].

A remote authenticated user can exploit a flaw in the MySQL Server Partition component to cause partial denial of service conditions [CVE-2015-0438].

A remote authenticated user can exploit a flaw in the MySQL Server Partition component to cause partial denial of service conditions [CVE-2015-0503].

A remote authenticated user can exploit a flaw in the MySQL Server Encryption component to cause partial denial of service conditions [CVE-2015-0441].

A remote authenticated user can exploit a flaw in the MySQL Server XA component to cause partial denial of service conditions [CVE-2015-0405].

A remote authenticated user can exploit a flaw in the MySQL Server DDL component to cause partial denial of service conditions [CVE-2015-0505].

A remote authenticated user can exploit a flaw in the MySQL Server Federated component to cause partial denial of service conditions [CVE-2015-0499].

A remote authenticated user can exploit a flaw in the MySQL Server InnoDB component to cause partial denial of service conditions [CVE-2015-0506].

A remote authenticated user can exploit a flaw in the MySQL Server memcached component to cause partial denial of service conditions [CVE-2015-0507].

A remote authenticated user can exploit a flaw in the MySQL Server Privileges component to cause partial denial of service conditions [CVE-2015-2567].

A remote user can exploit a flaw in the MySQL Server DML component to cause partial denial of service conditions [CVE-2015-2566].

A remote user can exploit a flaw in the MySQL Server SP component to cause partial denial of service conditions [CVE-2015-0511].

A local user can exploit a flaw in the MySQL Utilities Installation component to partially modify data [CVE-2015-2576].

A remote user can exploit a flaw in the MySQL Server Replication component to cause partial denial of service conditions [CVE-2015-0498].

The following researchers reported these and other Oracle product vulnerabilities:

An Anonymous Reporter working at HTL Leonding; Brandon Vincent; Christopher E. Walter; Daniel Ekberg of Swedish Public Employment Service; David Litchfield of Datacom TSS; Dmitry Janushkevich of Secunia Research; Florian Weimer of Red Hat;
Francis Provencher of Protek Research Lab; Jihui Lu of KeenTeam; Lupin LanYuShi; Mark Litchfield of Securatary; Markus Millbourn of Digifort; Martin Carpenter of Citco; Mateusz Jurczyk of Google Project Zero; Michael Miller of Integrigy;
Moshe Zioni of Comsec Consulting; Ofer Maor formerly of Hacktics; Paul M. Wright; Robbe De Keyzer of The Security Factory; Roberto Soares of Conviso Application Security; Sajith Shetty; Sasha Raljic; Shai Rod of Avnet Information Security;
Steven Seeley of HP's Zero Day Initiative; Tudor Enache of Help AG; Vishal V. Sonar of Control Case International Pvt Ltd.; and Wouter Coekaerts.

Impact:   A remote user can cause denial of service conditions on the target system.

A remote authenticated user can partially access and modify data on the target system.

A local user can partially modify data on the target system.

Solution:   The vendor has issued a fix as part of Oracle Critical Patch Update Advisory - April 2015.

The vendor's advisory is available at:

http://www.oracle.com/technetwork/topics/security/cpuapr2015-2365600.html

Vendor URL:  www.oracle.com/technetwork/topics/security/cpuapr2015-2365600.html (Links to External Site)
Cause:   Not specified
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Apr 21 2015 (Ubuntu Issues Fix) MySQL Multiple Bugs Let Remote Users Deny Service, Remote Authenticated Users Partially Access and Modify Data, and Local Users Partially Modify Data on the Target System
Ubuntu has issued a fix for Ubuntu 12.04 LTS, 14.04 LTS, and 14.10.
Aug 18 2015 (Red Hat Issues Fix) MySQL Multiple Bugs Let Remote Users Deny Service, Remote Authenticated Users Partially Access and Modify Data, and Local Users Partially Modify Data on the Target System
Red Hat has issued a fix for Red Hat Enterprise Linux 5.
Oct 16 2015 (Juniper Issues Fix for Juniper Junos Space) MySQL Multiple Bugs Let Remote Users Deny Service, Remote Authenticated Users Partially Access and Modify Data, and Local Users Partially Modify Data on the Target System
Juniper has issued a fix for Juniper Junos Space.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC