SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Forum/Board/Portal)  >   MyBB Vendors:   MyBB Group
MyBB Bugs Permit Cross-Site Scripting, Cross-Site Request Forgery, and Information Disclosure Attacks
SecurityTracker Alert ID:  1031953
SecurityTracker URL:  http://securitytracker.com/id/1031953
CVE Reference:   CVE-2015-2149, CVE-2015-2332, CVE-2015-2333, CVE-2015-2334, CVE-2015-2335, CVE-2015-2352   (Links to External Site)
Date:  Mar 19 2015
Impact:   Disclosure of authentication information, Disclosure of system information, Disclosure of user information, Execution of arbitrary code via network, Modification of user information, Not specified
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 1.8.4
Description:   Multiple vulnerabilities were reported in MyBB. A remote user can conduct cross-site scripting attacks. A remote user can conduct cross-site request forgery attacks. A remote user can determine the installation path. The impact of one vulnerability was not specified.

Several scripts do not properly filter HTML code from user-supplied input before displaying the input [CVE-2015-2149, CVE-2015-2332, CVE-2015-2333]. A remote user can cause arbitrary scripting code to be executed by the target user's browser. The code will originate from the site running the MyBB software and will run in the security context of that site. As a result, the code will be able to access the target user's cookies (including authentication cookies), if any, associated with the site, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

A remote user can create specially crafted HTML that, when loaded by the target user, will take actions on the target web site acting as the target user [CVE-2015-2334].

A remote user can exploit a flaw in a JSON library to determine the installation path [CVE-2015-2335].

The cache handler does not properly validate input he var_export() function [CVE-2015-2352]. The impact was not specified.

Impact:   A remote user can access the target user's cookies (including authentication cookies), if any, associated with the site running the MyBB software, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

A remote user can determine the installation path.

The impact of one vulnerability was not specified.

Solution:   The vendor has issued a fix (1.8.4).

The vendor's advisory is available at:

http://blog.mybb.com/2015/02/15/mybb-1-8-4-released-feature-update-security-maintenance-release/

Vendor URL:  blog.mybb.com/2015/02/15/mybb-1-8-4-released-feature-update-security-maintenance-release/ (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC