SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   phpMyAdmin Vendors:   phpMyAdmin Development Team
phpMyAdmin Bug May Disclose CSRF Token to Remote Users
SecurityTracker Alert ID:  1031871
SecurityTracker URL:  http://securitytracker.com/id/1031871
CVE Reference:   CVE-2015-2206   (Links to External Site)
Date:  Mar 10 2015
Impact:   Disclosure of system information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to versions 4.0.10.9, 4.2.13.2, 4.3.11.1
Description:   A vulnerability was reported in phpMyAdmin. A remote user can bypass cross-site request forgery protection.

A remote user can conduct a BREACH HTTP compression attack with a large number of specially crafted requests to determine the CSRF token value.

The vulnerability resides in 'libraries/select_lang.lib.php'.

Jian Jiang (https://www.linkedin.com/pub/jian-jiang/3a/660/775) and Xiaofeng Zheng (iliwoy@gmail.com) reported this vulnerability.

Impact:   A remote user can bypass cross-site request forgery protection.
Solution:   The vendor has issued a fix (4.0.10.9, 4.2.13.2, 4.3.11.1).

The vendor's advisory is available at:

http://www.phpmyadmin.net/home_page/security/PMASA-2015-1.php

Vendor URL:  www.phpmyadmin.net/home_page/security/PMASA-2015-1.php (Links to External Site)
Cause:   Access control error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2020, SecurityGlobal.net LLC