SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


Try our Premium Alert Service
 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service





Category:   Application (Multimedia)  >   Adobe Flash Vendors:   Adobe Systems Incorporated
Adobe Flash Player Multiple Flaws Let Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1031706
SecurityTracker URL:  http://securitytracker.com/id/1031706
CVE Reference:   CVE-2015-0314, CVE-2015-0315, CVE-2015-0316, CVE-2015-0317, CVE-2015-0318, CVE-2015-0319, CVE-2015-0320, CVE-2015-0321, CVE-2015-0322, CVE-2015-0323, CVE-2015-0324, CVE-2015-0325, CVE-2015-0326, CVE-2015-0327, CVE-2015-0328, CVE-2015-0329, CVE-2015-0330, CVE-2015-0331   (Links to External Site)
Updated:  Mar 2 2015
Original Entry Date:  Feb 5 2015
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 16.0.0.296 and prior (Windows/Mac); 13.0.0.264 and prior 13.x; 11.2.202.440 and prior (Linux)
Description:   Multiple vulnerabilities were reported in Adobe Flash Player. A remote user can cause arbitrary code to be executed on the target user's system.

A remote user can create specially crafted content that, when loaded by the target user, will execute arbitrary code on the target system. The code will run with the privileges of the target user.

A use-after-free may occur [CVE-2015-0315, CVE-2015-0320, CVE-2015-0322, CVE-2015-0331].

A memory corruption flaw may occur [CVE-2015-0314, CVE-2015-0316, CVE-2015-0318, CVE-2015-0321, CVE-2015-0329, CVE-2015-0330].

A type confusion error may occur [CVE-2015-0317, CVE-2015-0319].

A heap overflow may occur [CVE-2015-0323, CVE-2015-0327].

A buffer overflow may occur [CVE-2015-0324].

A null pointer dereference may occur [CVE-2015-0325, CVE-2015-0326, CVE-2015-0328].

bilou (via HP's Zero Day Initiative and via the Chromium Vulnerability Rewards Program), Robert Swiecki of Google, Mark Brand of Google Project Zero, Natalie Silvanovich (via Google Project Zero), Anonymous (via the Chromium Vulnerability Rewards Program), Jihui Lu of KeenTeam (via the Chromium Vulnerability Rewards Program), Ian Beer of Google Project Zero, and Wen Guanxing from Venustech ADLAB reported these vulnerabilities.

Impact:   A remote user can create Flash content that, when loaded by the target user, will execute arbitrary code on the target user's system.
Solution:   The vendor has issued a fix (16.0.0.305, ESR 13.0.0.269, 11.2.202.442 for Linux).

The vendor's advisory is available at:

https://helpx.adobe.com/security/products/flash-player/apsb15-04.html

Vendor URL:  helpx.adobe.com/security/products/flash-player/apsb15-04.html (Links to External Site)
Cause:   Access control error, Boundary error
Underlying OS:  Linux (Any), UNIX (macOS/OS X), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Feb 5 2015 (Microsoft Issues Fix for Internet Explorer) Adobe Flash Player Multiple Flaws Let Remote Users Execute Arbitrary Code
Microsoft has issued a fix for Internet Explorer 10 and 11.
Feb 6 2015 (Red Hat Issues Fix) Adobe Flash Player Multiple Flaws Let Remote Users Execute Arbitrary Code
Red Hat has issued a fix for Red Hat Enterprise Linux 5 and 6.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2018, SecurityGlobal.net LLC