SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Cisco WebEx Meetings Server Vendors:   Cisco, WebEx
Cisco WebEx Meetings Server Bugs Let Remote Users Bypass Authentication, Conduct Cross-Site Scripting and Cross-Site Request Forgery Attacks, and Obtain Encrypted Passwords
SecurityTracker Alert ID:  1031517
SecurityTracker URL:  http://securitytracker.com/id/1031517
CVE Reference:   CVE-2014-8030, CVE-2014-8031, CVE-2014-8032, CVE-2014-8033   (Links to External Site)
Date:  Jan 9 2015
Impact:   Disclosure of authentication information, Disclosure of system information, Disclosure of user information, Execution of arbitrary code via network, Modification of user information, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   Several vulnerabilities were reported in Cisco WebEx Meetings Server. A remote user can bypass authentication. A remote user can conduct cross-site scripting attacks. A remote user can conduct cross-site request forgery attacks. A remote authenticated user can obtain encrypted passwords.

The 'sendPwMail.do' page does not properly filter HTML code from user-supplied input before displaying the input [CVE-2014-8030]. A remote user can cause arbitrary scripting code to be executed by the target user's browser. The code will originate from the site running the Cisco WebEx Meetings Server software and will run in the security context of that site. As a result, the code will be able to access the target user's cookies (including authentication cookies), if any, associated with the site, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

The vendor has assigned bug ID CSCuj40381 to this vulnerability.

A remote user can conduct cross-site request forgery attacks to take actions on the interface acting as the target user [CVE-2014-8031].

The vendor has assigned bug ID CSCuj40456 to this vulnerability.

A remote authenticated user can exploit a flaw in the OutlookAction class to "generate sensitive encrypted values" [CVE-2014-8032].

The vendor has assigned bug IDs CSCuj40453 and CSCuj40449 to this vulnerability.

A remote user can send specially crafted URL requests to an exposed API to gain administrator access [CVE-2014-8033].

The vendor has assigned bug ID CSCuj40421 to this vulnerability.

Impact:   A remote user can bypass authentication and gain administrative access.

A remote user can access the target user's cookies (including authentication cookies), if any, associated with the site running the Cisco WebEx Meetings Server software, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

A remote authenticated user can obtain encrypted passwords.

Solution:   The vendor has issued a fix.

The vendor's advisory is available at:

http://tools.cisco.com/security/center/content/CiscoSecurityNotice/CVE-2014-8030

Vendor URL:  tools.cisco.com/security/center/content/CiscoSecurityNotice/CVE-2014-8030 (Links to External Site)
Cause:   Access control error, Input validation error

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC