SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Apache Struts Vendors:   Apache Software Foundation
Apache Struts Predictable Tokens Let Remote Users Bypass Cross-Site Request Forgery Protection
SecurityTracker Alert ID:  1031309
SecurityTracker URL:  http://securitytracker.com/id/1031309
CVE Reference:   CVE-2014-7809   (Links to External Site)
Date:  Dec 8 2014
Impact:   Modification of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 2.0.0 - 2.3.16.3
Description:   A vulnerability was reported in Apache Struts. A remote user can bypass cross-site request forgery protections.

A remote user can predict the token values used to prevent cross-site request forgery attacks.

Applications that use <s:token/> support are affected.

Philippe Arteau of Groupe Technologies Desjardins reported this vulnerability.

Impact:   A remote user can bypass the cross-site request forgery protection.
Solution:   The vendor has issued a fix (2.3.20).

The vendor's advisory is available at:

http://struts.apache.org/docs/s2-023.html

Vendor URL:  struts.apache.org/docs/s2-023.html (Links to External Site)
Cause:   Randomization error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC