SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Multimedia)  >   Apple QuickTime Vendors:   Apple
Apple QuickTime Buffer Overflow in Processing Audio Samples Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1031065
SecurityTracker URL:  http://securitytracker.com/id/1031065
CVE Reference:   CVE-2014-4351   (Links to External Site)
Updated:  Oct 22 2014
Original Entry Date:  Oct 17 2014
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   A vulnerability was reported in QuickTime. A remote user can cause arbitrary code to be executed on the target user's system.

A remote user can create an 'm4a' file containing specially crafted audio samples that, when loaded by the target user, will trigger a buffer overflow and execute arbitrary code on the target system. The code will run with the privileges of the target user.

Karl Smith of NCC Group reported this vulnerability.

Impact:   A remote user can create a file that, when loaded by the target user, will execute arbitrary code on the target user's system.
Solution:   The vendor has issued a fix (OS X 10.10; 7.7.6 for Windows).

The vendor's advisory is available at:

https://support.apple.com/kb/HT6535

Vendor URL:  support.apple.com/kb/HT6535 (Links to External Site)
Cause:   Boundary error
Underlying OS:  UNIX (macOS/OS X), Windows (Any)
Underlying OS Comments:  prior to OS X 10.10; Windows is also affected

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2020, SecurityGlobal.net LLC