SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Web Server/CGI)  >   Squid Vendors:   Squid-cache.org
Squid Range Header Processing Flaw Lets Remote Users Deny Service
SecurityTracker Alert ID:  1030779
SecurityTracker URL:  http://securitytracker.com/id/1030779
CVE Reference:   CVE-2014-3609   (Links to External Site)
Date:  Aug 29 2014
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 3.x prior to 3.3.13; 3.4.x prior to 3.4.7
Description:   A vulnerability was reported in Squid. A remote user can cause denial of service conditions.

A remote user can send a specially crafted Range header to cause denial of service conditions.

Matthew Daley reported this vulnerability.

Impact:   A remote user can cause denial of service conditions.
Solution:   The vendor has issued a fix (3.3.13, 3.4.7).

The vendor's advisory is available at:

http://www.squid-cache.org/Advisories/SQUID-2014_2.txt

Vendor URL:  www.squid-cache.org/Advisories/SQUID-2014_2.txt (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Any), UNIX (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Sep 3 2014 (Red Hat Issues Fix) Squid Range Header Processing Flaw Lets Remote Users Deny Service
Red Hat has issued a fix for Red Hat Enterprise Linux 5, 6, and 7.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC