SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Bugzilla Vendors:   Mozilla.org
Bugzilla Input Validation Flaw in JSONP Endpoint Permits Cross-Site Request Forgery Attacks
SecurityTracker Alert ID:  1030648
SecurityTracker URL:  http://securitytracker.com/id/1030648
CVE Reference:   CVE-2014-1546   (Links to External Site)
Date:  Jul 25 2014
Impact:   Disclosure of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to versions 4.0.13, 4.2.9, 4.4.4, 4.5.4
Description:   A vulnerability was reported in Bugzilla. A remote user can conduct cross-site request forgery attacks.

A remote user can create a specially crafted SWF file that, when loaded by a target user, will take actions against the JSONP endpoint to obtain potentially sensitive bug information.

Impact:   A remote user can take actions on the site acting as the target user to obtain potentially sensitive information about bugs.
Solution:   The vendor has issued a fix (4.0.13, 4.2.9, 4.4.4, 4.5.4).

The vendor's advisory is available at:

http://www.bugzilla.org/security/4.0.13/

Vendor URL:  www.bugzilla.org/security/4.0.13/ (Links to External Site)
Cause:   Access control error, Input validation error
Underlying OS:  Linux (Any), UNIX (Any)

Message History:   None.


 Source Message Contents

Subject:  Security advisory for Bugzilla 4.5.5, 4.4.5, 4.2.10, and 4.0.14

Summary
=======

Bugzilla is a Web-based bug-tracking system used by a large number of
software projects. The following security issue has been discovered
in Bugzilla:

* An attacker can get access to some bug information using
  the victim's credentials using a specially crafted HTML page.

All affected installations are encouraged to upgrade as soon as
possible.


Vulnerability Details
=====================

Class:       Cross Site Request Forgery
Versions:    3.7.1 to 4.0.13, 4.1.1 to 4.2.9, 4.3.1 to 4.4.4, 4.5.1 to 4.5.4
Fixed In:    4.0.14, 4.2.10, 4.4.5, 4.5.5
Description: Adobe does not properly restrict the SWF file format,
             which allows remote attackers to conduct cross-site
             request forgery (CSRF) attacks against Bugzilla's JSONP
             endpoint, possibly obtaining sensitive bug information,
             via a crafted OBJECT element with SWF content satisfying
             the character-set requirements of a callback API.
References:  https://bugzilla.mozilla.org/show_bug.cgi?id=1036213
CVE Number:  CVE-2014-1546


Vulnerability Solutions
=======================

The fixes for these issues are included in the 4.0.14, 4.2.10, 4.4.5, and 4.5.5
releases. Upgrading to a release with the relevant fixes will protect your
installation from possible exploits of this issue.

If you are unable to upgrade but would like to patch just these
individual security vulnerabilities, there are patches available for
the issues at the "References" URL for each vulnerability.

Full release downloads, patches to upgrade Bugzilla from previous
versions, and CVS/bzr upgrade instructions are available at:

  http://www.bugzilla.org/download/


Credits
=======

The Bugzilla team wish to thank the following people/organizations for
their assistance in locating, advising us of, and assisting us in fixing
these issues:

Mario Gomes
Reed Loden
Simon Green
Byron Jones

General information about the Bugzilla bug-tracking system can be found
at:

  http://www.bugzilla.org/

Comments and follow-ups can be directed to the mozilla.support.bugzilla
newsgroup or the support-bugzilla mailing list.
http://www.bugzilla.org/support/ has directions for accessing these
forums.
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC