SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   VMware vCenter Vendors:   VMware
(VMware Issues Fix for vCenter Operations Management Suite) Apache Struts Bugs Let Remote Users Deny Service and Manipulate the ClassLoader
SecurityTracker Alert ID:  1030460
SecurityTracker URL:  http://securitytracker.com/id/1030460
CVE Reference:   CVE-2014-0050, CVE-2014-0094   (Links to External Site)
Date:  Jun 25 2014
Impact:   Denial of service via network, Disclosure of system information, Modification of system information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): vCOPS 5.7.x, 5.8.x
Description:   Two vulnerabilities were reported in Apache Struts. A remote user can cause denial of service conditions. A remote user can manipulate the ClassLoader. VMware vCenter Operations Management Suite is affected.

A remote user can supply specially crafted 'class' parameter values to the ParametersInterceptor class to manipulate the ClassLoader [CVE-2014-0094].

A remote user can send a multipart request with a specially crafted Content-Type header to to trigger a flaw in the Apache Commons FileUpload component and cause denial of service conditions [CVE-2014-0050].

Mark Thomas and Przemyslaw Celej reported these vulnerabilities.

Impact:   A remote user can cause denial of service conditions.

A remote user can manipulate the ClassLoader.

Solution:   VMware has issued a fix for vCenter Operations Management Suite (vCOPS) (5.8.2).

A patch is pending for version 5.7.x.

The VMware advisory is available at:

http://www.vmware.com/security/advisories/VMSA-2014-0007.html

Vendor URL:  struts.apache.org/release/2.3.x/docs/s2-020.html (Links to External Site)
Cause:   Access control error, Input validation error, State error

Message History:   This archive entry is a follow-up to the message listed below.
Mar 6 2014 Apache Struts Bugs Let Remote Users Deny Service and Manipulate the ClassLoader



 Source Message Contents

Subject:  [Security-announce] NEW VMSA-2014-0007 - VMware product updates address security vulnerabilities in Apache Struts library

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- ------------------------------------------------------------------------
                   VMware Security Advisory

Advisory ID: VMSA-2014-0007
Synopsis:    VMware product updates address security vulnerabilities in 
             Apache Struts library 
Issue date:  2014-06-24
Updated on:  2014-06-24 (Initial Advisory)
CVE number:  CVE-2014-0050, CVE-2014-0094, CVE-2014-0112
- ------------------------------------------------------------------------

1. Summary

    VMware product updates address security vulnerabilities in Apache 
    Struts library

2. Relevant releases

    VMware vCenter Operations Management Suite prior to 5.8.2

3. Problem Description

   a. The Apache Struts library is updated to version 2.3.16.2 to 
      address multiple security issues.

      The Common Vulnerabilities and Exposures project (cve.mitre.org)
      has assigned the names CVE-2014-0050, CVE-2014-0094, and
      CVE-2014-0112 to these issues. 

      CVE-2014-0112 may lead to remote code execution. This issue was 
      found to be only partially addressed in CVE-2014-0094.

      CVE-2014-0050 may lead to a denial of service condition.

      vCenter Operations Management Suite (vCOps) is affected by both 
      CVE-2014-0112 and CVE-2014-0050. Exploitation of CVE-2014-0112
      may lead to remote code execution without authentication. 

      vCenter Orchestrator (vCO) is affected by CVE-2014-0050 and not 
      by CVE-2014-0112.

      Workaround

      A workaround for CVE-2014-0112 is documented in VMware Knowledge Base
      article 2081470.


      Column 4 of the following table lists the action required to
      remediate the vulnerability in each release, if a solution is 
      available.

      VMware         Product	Running	Replace with/
      Product        Version	on	Apply Patch
      =============  =======	=======	=================
      vCOPS	     5.8.x 	any 	vCOPS 5.8.2
      vCOPS          5.7.x      any     patch pending *

      vCO            5.5        any     patch pending
      vCO            5.1        any     patch pending
      vCO            4.2        any     patch pending

      *Customers are advised to apply the workaround or update to vCOps
5.8.2.

4. Solution

   Please review the patch/release notes for your product and version 
   and verify the checksum of your downloaded file. 

   vCenter Operations Management Suite 5.8.2
   -----------------------------------------
   Downloads and Documentation:
   https://www.vmware.com/go/download-vcops
   
5. References

   http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-0050
   http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-0094
   http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-0112

   http://kb.vmware.com/kb/2081470

- ------------------------------------------------------------------------

6. Change log

   2014-06-24 VMSA-2014-0007
   Initial security advisory in conjunction with the release of vCenter
   Operations Management Suite 5.8.2 on 2014-06-24.

- ------------------------------------------------------------------------

7. Contact

   E-mail list for product security notifications and announcements:
   http://lists.vmware.com/cgi-bin/mailman/listinfo/security-announce

   This Security Advisory is posted to the following lists:

    security-announce at lists.vmware.com
    bugtraq at securityfocus.com
    fulldisclosure at seclists.org

   E-mail: security at vmware.com
   PGP key at: http://kb.vmware.com/kb/1055

   VMware Security Advisories
   http://www.vmware.com/security/advisories

   VMware Security Response Policy
   https://www.vmware.com/support/policies/security_response.html

   VMware Lifecycle Support Phases
   https://www.vmware.com/support/policies/lifecycle.html
 
   Twitter
   https://twitter.com/VMwareSRC

   Copyright 2014 VMware Inc.  All rights reserved.

-----BEGIN PGP SIGNATURE-----
Version: Encryption Desktop 10.3.2 (Build 15337)
Charset: utf-8

wj8DBQFTqi0BDEcm8Vbi9kMRAnCKAJ9otVO7DlXuMnSEGh2TLBzS5hniKgCeMnAM
CZ5+DYZAydCjMwVgtKqoo7Y=
=Vwu5
-----END PGP SIGNATURE-----
_______________________________________________
Security-announce mailing list
Security-announce@lists.vmware.com
http://lists.vmware.com/mailman/listinfo/security-announce
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC