SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (E-mail Client)  >   Mozilla Thunderbird Vendors:   Mozilla.org
Mozilla Thunderbird Multiple Flaws Let Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1030386
SecurityTracker URL:  http://securitytracker.com/id/1030386
CVE Reference:   CVE-2014-1533, CVE-2014-1534, CVE-2014-1536, CVE-2014-1537, CVE-2014-1538, CVE-2014-1541   (Links to External Site)
Date:  Jun 11 2014
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 24.6
Description:   Several vulnerabilities were reported in Mozilla Thunderbird. A remote user can cause arbitrary code to be executed on the target user's system.

A remote user can create specially crafted content that, when loaded by the target user, will trigger a memory corruption, use-after-free, or boundary error and execute arbitrary code on the target system. The code will run with the privileges of the target user.

Gary Kwong, Christoph Diehl, Christian Holler, Hannes Verschore, Jan de Mooij, Ryan VanderMeulen, Jeff Walden, Kyle Huey, Jesse Ruderman, Gregor Wagner, Benoit Jacob, Karl Tomlinson, Abhishek Arya (Inferno) of the Google Chrome Security Team, and Nils reported these vulnerabilities.

Impact:   A remote user can create a file that, when loaded by the target user, will execute arbitrary code on the target user's system.
Solution:   The vendor has issued a fix (24.6).

The vendor's advisories available at:

http://www.mozilla.org/security/announce/2014/mfsa2014-48.html
http://www.mozilla.org/security/announce/2014/mfsa2014-49.html
http://www.mozilla.org/security/announce/2014/mfsa2014-52.html

Vendor URL:  www.mozilla.org/security/announce/2014/mfsa2014-48.html (Links to External Site)
Cause:   Access control error, Boundary error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Jun 11 2014 (Red Hat Issues Fix) Mozilla Thunderbird Multiple Flaws Let Remote Users Execute Arbitrary Code
Red Hat has issued a fix for Red Hat Enterprise Linux 5 and 6.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC