SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Web Server/CGI)  >   nginx Vendors:   nginx.org
nginx Heap Overflow in SPDY Implementation Lets Remote Users Exec ute Arbitrary Code
SecurityTracker Alert ID:  1030151
SecurityTracker URL:  http://securitytracker.com/id/1030151
CVE Reference:   CVE-2014-0133   (Links to External Site)
Date:  Apr 24 2014
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 1.3.15 - 1.5.11
Description:   A vulnerability was reported in nginx. A remote user can execute arbitrary code on the target system.

A remote user can send specially crafted data to trigger a heap overflow in the SPDY implementation and execute arbitrary code on the target system.

Systems compiled with the ngx_http_spdy_module module and without the '--with-debug configure' option and configured with the 'spdy' option of the 'listen' are affected.

Lucas Molas, researcher at Programa STIC, Fundacion and Dr. Manuel Sadosky, Buenos Aires, Argentina reported this vulnerability.

Impact:   A remote user can execute arbitrary code on the target system.
Solution:   The vendor has issued a fix (1.4.7, 1.5.12) [in March 2014].

A patch is also available at:

http://nginx.org/download/patch.2014.spdy2.txt

The vendor's advisory is available at:

http://mailman.nginx.org/pipermail/nginx-announce/2014/000135.html

Vendor URL:  mailman.nginx.org/pipermail/nginx-announce/2014/000135.html (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC