SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Apache Archiva Vendors:   Apache Software Foundation
Apache Archiva Input Validation Flaw Permits Cross-Site Scripting Attacks
SecurityTracker Alert ID:  1030130
SecurityTracker URL:  http://securitytracker.com/id/1030130
CVE Reference:   CVE-2013-2187   (Links to External Site)
Date:  Apr 21 2014
Impact:   Disclosure of authentication information, Disclosure of user information, Execution of arbitrary code via network, Modification of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 1.2 to 1.2.2, 1.3 to 1.3.6
Description:   A vulnerability was reported in Apache Archiva. A remote user can conduct cross-site scripting attacks.

The Archiva home page does not properly filter HTML code from user-supplied input before displaying the input. A remote user can create a specially crafted URL that, when loaded by a target user, will cause arbitrary scripting code to be executed by the target user's browser. The code will originate from the site running the Apache Archiva software and will run in the security context of that site. As a result, the code will be able to access the target user's cookies (including authentication cookies), if any, associated with the site, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

Impact:   A remote user can access the target user's cookies (including authentication cookies), if any, associated with the site running the Apache Archiva software, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.
Solution:   The vendor has issued a fix (1.3.8, 2.0.1).

The vendor's advisory is available at:

http://archiva.apache.org/security.html

Vendor URL:  archiva.apache.org/security.html (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Subject:  [SECURITY] CVE-2013-2187: Apache Archiva Cross-Site Scripting vulnerability

CVE-2013-2187: Apache Archiva Cross-Site Scripting vulnerability

Severity: Important

Vendor: The Apache Software Foundation

Versions Affected:
- Archiva 1.3 to Continuum 1.3.6
- The unsupported versions Archiva 1.2 to 1.2.2 are also affected.

Description:
A request that included a specially crafted request parameter could be used to inject arbitrary HTML or Javascript into the Archiva home page.

Mitigation:
All users are recommended to upgrade to Archiva 2.0.1 or Archiva 1.3.8, which are not affected by this issue.

Archiva 2.0.0 and later is not affected by this issue.

References:
http://archiva.apache.org/security.html



 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC