SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Forum/Board/Portal)  >   WordPress Vendors:   wordpress.org
WordPress Bugs Let Remote Users Bypass Authentication and Remote Authenticated Users Gain Elevated Privileges
SecurityTracker Alert ID:  1030071
SecurityTracker URL:  http://securitytracker.com/id/1030071
CVE Reference:   CVE-2014-0165, CVE-2014-0166   (Links to External Site)
Date:  Apr 11 2014
Impact:   Modification of user information, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to versions 3.7.2 and 3.8.2
Description:   Two vulnerabilities were reported in WordPress. A remote user can bypass authentication on the target system. A remote authenticated user can gain elevated privileges.

A remote authenticated user can exploit a flaw in 'wp-admin/includes/post.php' and 'wp-admin/includes/class-wp-posts-list-table.php' to publish posts [CVE-2014-0165].

A remote user can supply a specially crafted cookie value to trigger a flaw in the wp_validate_auth_cookie() function in 'wp-includes/pluggable.php' and bypass authentication [CVE-2014-0166].

Impact:   A remote user can bypass authentication on the target system.

A remote authenticated user can gain elevated privileges.

Solution:   The vendor has issued a fix (3.7.2, 3.8.2).

The vendor's advisory is available at:

http://wordpress.org/news/2014/04/wordpress-3-8-2/

Vendor URL:  wordpress.org/news/2014/04/wordpress-3-8-2/ (Links to External Site)
Cause:   Access control error, Authentication error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC