SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (VPN)  >   GnuTLS Vendors:   gnutls.org
GnuTLS Intermediate Certificate Processing Flaw May Let Remote Users Bypass Certificate Validation
SecurityTracker Alert ID:  1029766
SecurityTracker URL:  http://securitytracker.com/id/1029766
CVE Reference:   CVE-2014-1959   (Links to External Site)
Date:  Feb 14 2014
Impact:   Disclosure of user information, Modification of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 3.1.x, 3.2.x
Description:   A vulnerability was reported in GnuTLS. A remote user can bypass certificate validation in certain cases.

An X.509 version 1 intermediate certificate is incorrectly considered as a Certificate Authority (CA) certificate.

Systems with a CA that issues X.509 version 1 certificates in the trusted list are affected.

The vulnerability resides in 'lib/x509/verify.c'.

Suman Jana reported this vulnerability.

Impact:   A remote user can bypass certificate validation in certain cases.
Solution:   The vendor has issued a fix (3.1.21, 3.2.11).

The vendor's advisory is available at:

http://gnutls.org/security.html

Vendor URL:  gnutls.org/ (Links to External Site)
Cause:   Authentication error
Underlying OS:  Linux (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC