SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Web Browser)  >   Mozilla Firefox Vendors:   Mozilla.org
Mozilla Firefox Multiple Flaws Let Remote Users Deny Service and Execute Arbitrary Code and Let Local Users Gain Elevated Privileges
SecurityTracker Alert ID:  1029042
SecurityTracker URL:  http://securitytracker.com/id/1029042
CVE Reference:   CVE-2013-1718, CVE-2013-1719, CVE-2013-1720, CVE-2013-1721, CVE-2013-1722, CVE-2013-1723, CVE-2013-1724, CVE-2013-1725, CVE-2013-1726, CVE-2013-1727, CVE-2013-1728, CVE-2013-1729, CVE-2013-1730, CVE-2013-1731, CVE-2013-1732, CVE-2013-1735, CVE-2013-1736, CVE-2013-1737, CVE-2013-1738   (Links to External Site)
Updated:  Sep 17 2013
Original Entry Date:  Sep 17 2013
Impact:   Denial of service via network, Disclosure of authentication information, Disclosure of system information, Disclosure of user information, Execution of arbitrary code via network, Modification of user information, User access via local system, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 24.0; prior to ESR 17.0.9
Description:   Multiple vulnerabilities were reported in Mozilla Firefox. A remote user can cause arbitrary code to be executed on the target user's system. A local user can obtain elevated privileges on the target system. A remote user can cause denial of service conditions. A remote user can conduct cross-site scripting attacks.

A remote user can create specially crafted HTML that, when loaded by the target user, will trigger a buffer overflow, integer overflow, or memory corruption error and execute arbitrary code on the target system [CVE-2013-1718, CVE-2013-1719, CVE-2013-1720, CVE-2013-1721, CVE-2013-1722, CVE-2013-1724, CVE-2013-1725, CVE-2013-1726, CVE-2013-1728, CVE-2013-1732, CVE-2013-1735, CVE-2013-1736, CVE-2013-1738]. The code will run with the privileges of the target user.

The Mozilla Updater does not write-lock the MAR update file when it is in use by the Updater [CVE-2013-1726]. A local user can modify the update MAR file to run arbitrary code with the privileges of the Mozilla Updater.

A local user can bypass same-origin policy using 'file://' and symbolic links to conduct cross-site scripting attacks or access to locally stored Firefox files containing passwords and cookies [CVE-2013-1727]. Firefox for Android is affected.

A remote user can exploit a flaw in the NVIDIA OS X graphic drivers to access portions of the target user's desktop or other visible applications [CVE-2013-1729].

An Android application can exploit a shared object directory permissions flaw to access Firefox data or cause Firefox to execute arbitrary code [CVE-2013-1731].

A remote user can exploit a flaw in XBL-backed nodes to potentially crash the application or execute arbitrary code [CVE-2013-1730].

Some user-defined properties may be processed incorrectly, allowing users to bypass security controls [CVE-2013-1737].

The NativeKey widget continues handling key messages even when it is destroyed by dispatched event listeners [CVE-2013-1723]. As a result, a remote user can cause the target application to crash.

The following researchers reported these vulnerabilities:

Andre Bargull, Scoobidiver, Bobby Holley, Reuben Morais, Christian Holler, Makoto Kato, Jesse Ruderman, Jason Smith, Jan de Mooij, Gary Kwong, Olli Pettay, Bob Clary, Atte Kettunen, Alex Chapman, Abhishek Arya (Inferno), Masayuki Nakano, Scott Bell, Ms2ger, Seb Patane, Takeshi Terada, Dan Gohman, Victor Porof, Vladimir Vukicevic, Sachin Shinde, Aki Helin, Nils, and Boris Zbarsky.

Impact:   A remote user can create HTML that, when loaded by the target user, will execute arbitrary code on the target user's system.

A remote user can cause denial of service conditions.

A local user can obtain elevated privileges on the target system.

A remote user can conduct cross-site scripting attacks.

Solution:   The vendor has issued a fix (24.0; ESR 17.0.9).

The vendor's advisories are available at:

http://www.mozilla.org/security/announce/2013/mfsa2013-76.html
http://www.mozilla.org/security/announce/2013/mfsa2013-77.html
http://www.mozilla.org/security/announce/2013/mfsa2013-78.html
http://www.mozilla.org/security/announce/2013/mfsa2013-79.html
http://www.mozilla.org/security/announce/2013/mfsa2013-80.html
http://www.mozilla.org/security/announce/2013/mfsa2013-81.html
http://www.mozilla.org/security/announce/2013/mfsa2013-82.html
http://www.mozilla.org/security/announce/2013/mfsa2013-83.html
http://www.mozilla.org/security/announce/2013/mfsa2013-84.html
http://www.mozilla.org/security/announce/2013/mfsa2013-85.html
http://www.mozilla.org/security/announce/2013/mfsa2013-86.html
http://www.mozilla.org/security/announce/2013/mfsa2013-87.html
http://www.mozilla.org/security/announce/2013/mfsa2013-88.html
http://www.mozilla.org/security/announce/2013/mfsa2013-89.html
http://www.mozilla.org/security/announce/2013/mfsa2013-90.html
http://www.mozilla.org/security/announce/2013/mfsa2013-91.html
http://www.mozilla.org/security/announce/2013/mfsa2013-92.html

Vendor URL:  www.mozilla.org/security/announce/2013/mfsa2013-76.html (Links to External Site)
Cause:   Access control error, Boundary error, Input validation error
Underlying OS:  Android, Linux (Any), UNIX (Any), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Sep 17 2013 (Red Hat Issues Fix) Mozilla Firefox Multiple Flaws Let Remote Users Deny Service and Execute Arbitrary Code and Let Local Users Gain Elevated Privileges
Red Hat has issued a fix for Red Hat Enterprise Linux.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2020, SecurityGlobal.net LLC