SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Web Server/CGI)  >   nginx Vendors:   nginx.org
nginx Stack Overflow Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1028519
SecurityTracker URL:  http://securitytracker.com/id/1028519
CVE Reference:   CVE-2013-2028   (Links to External Site)
Date:  May 7 2013
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 1.3.9 - 1.4.0
Description:   A vulnerability was reported in nginx. A remote user can execute arbitrary code on the target system.

A remote user can send a specially crafted request to trigger a stack overflow and execute arbitrary code on the target system.

Greg MacManus of iSIGHT Partners Labs reported this vulnerability.

Impact:   A remote user can execute arbitrary code on the target system.
Solution:   The vendor has issued a fix (1.4.1, 1.5.0).

A patch is also available at:

http://nginx.org/download/patch.2013.chunked.txt

Vendor URL:  nginx.org/ (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC