SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   VMware Vendors:   VMware
(VMware Issues Fix for VMware vFabric Postgres) PostgreSQL Bugs Let Remote Users Deny Service and Let Local Users Gain Elevated Privileges
SecurityTracker Alert ID:  1028390
SecurityTracker URL:  http://securitytracker.com/id/1028390
CVE Reference:   CVE-2013-1899, CVE-2013-1900, CVE-2013-1901   (Links to External Site)
Date:  Apr 5 2013
Impact:   Denial of service via network, Execution of arbitrary code via network, User access via local system, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): VMware vFabric Postgres 9.1.6 and prior; 9.2.2 and prior
Description:   Several vulnerabilities were reported in PostgreSQL. A remote user can cause denial of service conditions on the target system. A remote authenticated user can execute arbitrary code on the target system. A local user can obtain elevated privileges on the target system. VMware vFabric Postgres is affected by some vulnerabilities.

A remote user can send a specially crafted connection request containing a database name that begins with '-' [CVE-2013-1899] to damage or destroy files on the target system's data directory. In certain cases, a remote authenticated user can exploit this to execute arbitrary code on the target system.

Mitsumasa Kondo and Kyotaro Horiguchi of NTT Open Source Software Center reported this vulnerability.

The random numbers generated by contrib/pgcrypto functions may make it easier for another database user to guess [CVE-2013-1900].

A remote authenticated but unprivileged user can execute commands that may interfere with in-progress backups [CVE-2013-1901].

On Linux-based and Mac OS X-based systems, superuser passwords are insecurely passed to a script during installation [CVE-2013-1903].

On Linux-based and Mac OS X-based systems, the system uses predictable filenames in the '/tmp' directory during installation [CVE-2013-1902].

Marko Kreen, Noah Misch, and Stefan Kaltenbrunner each reported one of these vulnerabilities.

Impact:   A remote authenticated user can execute arbitrary code on the target system.

A remote user can cause denial of service conditions on the target system.

A local user can obtain elevated privileges on the target system.

Solution:   VMware has issued a fix for CVE-2013-1899, CVE-2013-1900, and CVE-2013-1901 for VMware vFabric Postgres.

The VMware advisory is available at:

http://www.vmware.com/security/advisories/VMSA-2013-0005.html

Vendor URL:  www.postgresql.org/about/news/1456/ (Links to External Site)
Cause:   Access control error, Randomization error, State error

Message History:   This archive entry is a follow-up to the message listed below.
Apr 4 2013 PostgreSQL Bugs Let Remote Users Deny Service and Let Local Users Gain Elevated Privileges



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC