SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Foxit Reader Vendors:   Foxit Software
Foxit Reader Browser Plugin URL Processing Buffer Overflow Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1027953
SecurityTracker URL:  http://securitytracker.com/id/1027953
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  Jan 8 2013
Impact:   Execution of arbitrary code via network, User access via network
Exploit Included:  Yes  
Version(s): 5.4.3.0920, 5.4.4.1128; possibly other versions
Description:   A vulnerability was reported in Foxit Reader. A remote user can cause arbitrary code to be executed on the target user's system.

A remote user can create a specially crafted URL that, when loaded by the target user, will trigger a stack overflow in the browser plugin and execute arbitrary code on the target system. The code will run with the privileges of the target user.

The original advisory and demonstration exploit is available at:

http://retrogod.altervista.org/9sg_foxit_overflow.htm

Andrea Micalizzi aka rgod reported this vulnerability.

Impact:   A remote user can create a URL that, when loaded by the target user, will execute arbitrary code on the target user's system.
Solution:   No solution was available at the time of this entry.
Vendor URL:  www.foxitsoftware.com/ (Links to External Site)
Cause:   Boundary error
Underlying OS:  Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC