SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Sudo Vendors:   sudo.ws
Sudo on Red Hat Enterprise Linux %postun Symlink Flaw Lets Local Users Gain Elevated Privileges
SecurityTracker Alert ID:  1027356
SecurityTracker URL:  http://securitytracker.com/id/1027356
CVE Reference:   CVE-2012-3440   (Links to External Site)
Date:  Aug 8 2012
Impact:   Modification of system information, Modification of user information, Root access via local system, User access via local system
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   A vulnerability was reported in Sudo on Red Hat Enterprise Linux. A local user can obtain elevated privileges on the target system.

A local user can exploit a temporary file symbolic link flaw in the %postun script to overwrite arbitrary files or modify the contents of the "/etc/nsswitch.conf" file when the sudo package is upgraded or removed.

This can be exploited to gain elevated privileges on the target system.

Impact:   A local user can obtain elevated privileges on the target system.
Solution:   Red Hat has issued a fix.

The Red Hat advisory is available at:

https://rhn.redhat.com/errata/RHSA-2012-1149.html

Vendor URL:  www.sudo.ws/ (Links to External Site)
Cause:   Access control error
Underlying OS:  Linux (Red Hat Enterprise)
Underlying OS Comments:  5

Message History:   This archive entry has one or more follow-up message(s) listed below.
May 31 2013 (VMware Issues Fix for ESX) Sudo on Red Hat Enterprise Linux %postun Symlink Flaw Lets Local Users Gain Elevated Privileges
VMware has issued a fix for VMware ESX 4.0 and 4.1.



 Source Message Contents

Subject:  [RHSA-2012:1149-01] Moderate: sudo security and bug fix update

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Moderate: sudo security and bug fix update
Advisory ID:       RHSA-2012:1149-01
Product:           Red Hat Enterprise Linux
Advisory URL:      https://rhn.redhat.com/errata/RHSA-2012-1149.html
Issue date:        2012-08-07
CVE Names:         CVE-2012-3440 
=====================================================================

1. Summary:

An updated sudo package that fixes one security issue and several bugs is
now available for Red Hat Enterprise Linux 5.

The Red Hat Security Response Team has rated this update as having moderate
security impact. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available from the CVE link in
the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux (v. 5 server) - i386, ia64, ppc, s390x, x86_64
Red Hat Enterprise Linux Desktop (v. 5 client) - i386, x86_64

3. Description:

The sudo (superuser do) utility allows system administrators to give
certain users the ability to run commands as root.

An insecure temporary file use flaw was found in the sudo package's
post-uninstall script. A local attacker could possibly use this flaw to
overwrite an arbitrary file via a symbolic link attack, or modify the
contents of the "/etc/nsswitch.conf" file during the upgrade or removal of
the sudo package. (CVE-2012-3440)

This update also fixes the following bugs:

* Previously, sudo escaped non-alphanumeric characters in commands using
"sudo -s" or "sudo -" at the wrong place and interfered with the
authorization process. Some valid commands were not permitted. Now,
non-alphanumeric characters escape immediately before the command is
executed and no longer interfere with the authorization process.
(BZ#844418)

* Prior to this update, the sudo utility could, under certain
circumstances, fail to receive the SIGCHLD signal when it was executed
from a process that blocked the SIGCHLD signal. As a consequence, sudo
could become suspended and fail to exit. This update modifies the signal
process mask so that sudo can exit and sends the correct output.
(BZ#844419)

* The sudo update RHSA-2012:0309 introduced a regression that caused the
Security-Enhanced Linux (SELinux) context of the "/etc/nsswitch.conf" file
to change during the installation or upgrade of the sudo package. This
could cause various services confined by SELinux to no longer be permitted
to access the file. In reported cases, this issue prevented PostgreSQL and
Postfix from starting. (BZ#842759)

* Updating the sudo package resulted in the "sudoers" line in
"/etc/nsswitch.conf" being removed. This update corrects the bug in the
sudo package's post-uninstall script that caused this issue. (BZ#844420)

* Prior to this update, a race condition bug existed in sudo. When a
program was executed with sudo, the program could possibly exit
successfully before sudo started waiting for it. In this situation, the
program would be left in a zombie state and sudo would wait for it
endlessly, expecting it to still be running. (BZ#844978)

All users of sudo are advised to upgrade to this updated package, which
contains backported patches to correct these issues.

4. Solution:

Before applying this update, make sure all previously-released errata
relevant to your system have been applied.

This update is available via the Red Hat Network. Details on how to
use the Red Hat Network to apply this update are available at
https://access.redhat.com/knowledge/articles/11258

5. Bugs fixed (http://bugzilla.redhat.com/):

842759 - selinux blocks postgresql startup
844420 - sudo 1.7.2p1-14.el5_8 removed sudoers line from nsswitch.conf
844442 - CVE-2012-3440 sudo: insecure temporary file use in RPM %postun script
844978 - Sudo has racecondition leaving sudo with its zombie child running forever

6. Package List:

Red Hat Enterprise Linux Desktop (v. 5 client):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Client/en/os/SRPMS/sudo-1.7.2p1-14.el5_8.2.src.rpm

i386:
sudo-1.7.2p1-14.el5_8.2.i386.rpm
sudo-debuginfo-1.7.2p1-14.el5_8.2.i386.rpm

x86_64:
sudo-1.7.2p1-14.el5_8.2.x86_64.rpm
sudo-debuginfo-1.7.2p1-14.el5_8.2.x86_64.rpm

Red Hat Enterprise Linux (v. 5 server):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/os/SRPMS/sudo-1.7.2p1-14.el5_8.2.src.rpm

i386:
sudo-1.7.2p1-14.el5_8.2.i386.rpm
sudo-debuginfo-1.7.2p1-14.el5_8.2.i386.rpm

ia64:
sudo-1.7.2p1-14.el5_8.2.ia64.rpm
sudo-debuginfo-1.7.2p1-14.el5_8.2.ia64.rpm

ppc:
sudo-1.7.2p1-14.el5_8.2.ppc.rpm
sudo-debuginfo-1.7.2p1-14.el5_8.2.ppc.rpm

s390x:
sudo-1.7.2p1-14.el5_8.2.s390x.rpm
sudo-debuginfo-1.7.2p1-14.el5_8.2.s390x.rpm

x86_64:
sudo-1.7.2p1-14.el5_8.2.x86_64.rpm
sudo-debuginfo-1.7.2p1-14.el5_8.2.x86_64.rpm

These packages are GPG signed by Red Hat for security.  Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/#package

7. References:

https://www.redhat.com/security/data/cve/CVE-2012-3440.html
https://access.redhat.com/security/updates/classification/#moderate
https://rhn.redhat.com/errata/RHSA-2012-0309.html

8. Contact:

The Red Hat security contact is <secalert@redhat.com>.  More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2012 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.4 (GNU/Linux)

iD8DBQFQIV18XlSAg2UNWIIRArUrAJ0bm2PNKgJGSC2Yk3Dpab/NJwAL8gCcC2lm
N31JTQuqRSRZhGCgiXKUwyg=
=rPWG
-----END PGP SIGNATURE-----


--
RHSA-announce mailing list
RHSA-announce@redhat.com
https://www.redhat.com/mailman/listinfo/rhsa-announce
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2020, SecurityGlobal.net LLC