SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Adobe Acrobat/Reader Vendors:   Adobe Systems Incorporated
(Red Hat Issues Fix) Adobe Acrobat/Reader Multiple Bugs Let Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1026912
SecurityTracker URL:  http://securitytracker.com/id/1026912
CVE Reference:   CVE-2012-0774, CVE-2012-0775, CVE-2012-0777   (Links to External Site)
Date:  Apr 10 2012
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 9.5 and prior versions; 10.1.2 and prior versions
Description:   Several vulnerabilities were reported in Adobe Acrobat/Reader. A remote user can cause arbitrary code to be executed on the target user's system.

A remote user can create a specially crafted file that, when loaded by the target user, will trigger a memory corruption error and execute arbitrary code on the target system. The code will run with the privileges of the target user.

An integer overflow in True Type Font (TTF) handling can cause code execution [CVE-2012-0774].

A memory corruption error in JavaScript handling can cause code execution [CVE-2012-0775].

A security bypass via the Adobe Reader installer can cause code execution [CVE-2012-0776].

A memory corruption error in the JavaScript API can cause code execution on Mac OS X and Linux systems [CVE-2012-0777].

Peter Vreugdenhil, HP DVLabs, Soroush Dalili, Mitja Kolsek of ACROS Security, and James Quirk, Los Alamos, reported these vulnerabilities.

Impact:   A remote user can create a file that, when loaded by the target user, will execute arbitrary code on the target user's system.
Solution:   Red Hat has issued a fix for CVE-2012-0774, CVE-2012-0775, and CVE-2012-0777.

The Red Hat advisory is available at:

https://rhn.redhat.com/errata/RHSA-2012-0469.html

Vendor URL:  www.adobe.com/support/security/bulletins/apsb12-08.html (Links to External Site)
Cause:   Access control error, Boundary error
Underlying OS:  Linux (Red Hat Enterprise)
Underlying OS Comments:  5, 6

Message History:   This archive entry is a follow-up to the message listed below.
Apr 10 2012 Adobe Acrobat/Reader Multiple Bugs Let Remote Users Execute Arbitrary Code



 Source Message Contents

Subject:  [RHSA-2012:0469-01] Critical: acroread security update

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Critical: acroread security update
Advisory ID:       RHSA-2012:0469-01
Product:           Red Hat Enterprise Linux Extras
Advisory URL:      https://rhn.redhat.com/errata/RHSA-2012-0469.html
Issue date:        2012-04-10
CVE Names:         CVE-2012-0774 CVE-2012-0775 CVE-2012-0777 
=====================================================================

1. Summary:

Updated acroread packages that fix multiple security issues are now
available for Red Hat Enterprise Linux 5 and 6 Supplementary.

The Red Hat Security Response Team has rated this update as having critical
security impact. Common Vulnerability Scoring System (CVSS) base scores,
which give detailed severity ratings, are available for each vulnerability
from the CVE links in the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux Desktop Supplementary (v. 5) - i386, x86_64
Red Hat Enterprise Linux Desktop Supplementary (v. 6) - i386, x86_64
Red Hat Enterprise Linux Server Supplementary (v. 5) - i386, x86_64
Red Hat Enterprise Linux Server Supplementary (v. 6) - i386, x86_64
Red Hat Enterprise Linux Workstation Supplementary (v. 6) - i386, x86_64

3. Description:

Adobe Reader allows users to view and print documents in Portable Document
Format (PDF).

This update fixes multiple security flaws in Adobe Reader. These flaws are
detailed on the Adobe security page APSB12-08, listed in the References
section. A specially-crafted PDF file could cause Adobe Reader to crash or,
potentially, execute arbitrary code as the user running Adobe Reader when
opened. (CVE-2012-0774, CVE-2012-0775, CVE-2012-0777)

All Adobe Reader users should install these updated packages. They contain
Adobe Reader version 9.5.1, which is not vulnerable to these issues. All
running instances of Adobe Reader must be restarted for the update to take
effect.

4. Solution:

Before applying this update, make sure all previously-released errata
relevant to your system have been applied.

This update is available via the Red Hat Network. Details on how to
use the Red Hat Network to apply this update are available at
https://access.redhat.com/knowledge/articles/11258

5. Bugs fixed (http://bugzilla.redhat.com/):

810397 - CVE-2012-0774 CVE-2012-0775 CVE-2012-0777 acroread: multiple unspecified flaws (APSB12-08)

6. Package List:

Red Hat Enterprise Linux Desktop Supplementary (v. 5):

i386:
acroread-9.5.1-1.el5.i386.rpm
acroread-plugin-9.5.1-1.el5.i386.rpm

x86_64:
acroread-9.5.1-1.el5.i386.rpm
acroread-plugin-9.5.1-1.el5.i386.rpm

Red Hat Enterprise Linux Server Supplementary (v. 5):

i386:
acroread-9.5.1-1.el5.i386.rpm
acroread-plugin-9.5.1-1.el5.i386.rpm

x86_64:
acroread-9.5.1-1.el5.i386.rpm
acroread-plugin-9.5.1-1.el5.i386.rpm

Red Hat Enterprise Linux Desktop Supplementary (v. 6):

i386:
acroread-9.5.1-1.el6_2.i686.rpm
acroread-plugin-9.5.1-1.el6_2.i686.rpm

x86_64:
acroread-9.5.1-1.el6_2.i686.rpm
acroread-plugin-9.5.1-1.el6_2.i686.rpm

Red Hat Enterprise Linux Server Supplementary (v. 6):

i386:
acroread-9.5.1-1.el6_2.i686.rpm
acroread-plugin-9.5.1-1.el6_2.i686.rpm

x86_64:
acroread-9.5.1-1.el6_2.i686.rpm
acroread-plugin-9.5.1-1.el6_2.i686.rpm

Red Hat Enterprise Linux Workstation Supplementary (v. 6):

i386:
acroread-9.5.1-1.el6_2.i686.rpm
acroread-plugin-9.5.1-1.el6_2.i686.rpm

x86_64:
acroread-9.5.1-1.el6_2.i686.rpm
acroread-plugin-9.5.1-1.el6_2.i686.rpm

These packages are GPG signed by Red Hat for security.  Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/#package

7. References:

https://www.redhat.com/security/data/cve/CVE-2012-0774.html
https://www.redhat.com/security/data/cve/CVE-2012-0775.html
https://www.redhat.com/security/data/cve/CVE-2012-0777.html
https://access.redhat.com/security/updates/classification/#critical
http://www.adobe.com/support/security/bulletins/apsb12-08.html

8. Contact:

The Red Hat security contact is <secalert@redhat.com>.  More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2012 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.4 (GNU/Linux)

iD8DBQFPhKRJXlSAg2UNWIIRAsVrAJ9UzVzzjYFWUh47R5dgHQiRssfFOgCfWmLi
Icw8el8KnX3f3bgyqMCsWO0=
=NK8r
-----END PGP SIGNATURE-----


-- 
Enterprise-watch-list mailing list
Enterprise-watch-list@redhat.com
https://www.redhat.com/mailman/listinfo/enterprise-watch-list
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC