SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Adobe Acrobat/Reader Vendors:   Adobe Systems Incorporated
(Red Hat Issues Fix) Adobe Acrobat/Reader PRC Memory Corruption Error Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1026501
SecurityTracker URL:  http://securitytracker.com/id/1026501
CVE Reference:   CVE-2011-4369   (Links to External Site)
Date:  Jan 11 2012
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 10.1.1 and prior versions
Description:   A vulnerability was reported in Adobe Acrobat/Reader. A remote user can cause arbitrary code to be executed on the target user's system.

A remote user can create a specially crafted PDF file that, when loaded by the target user, will trigger a memory corruption error in the PRC component and execute arbitrary code on the target system. The code will run with the privileges of the target user.

This vulnerability is being actively exploited against Windows-based systems.

The vendor reports that Adobe Reader X Protected Mode and Adobe Acrobat X Protected View prevent the exploit from executing.

Lockheed Martin CIRT, MITRE, and members of the Defense Security Information Exchange reported this vulnerability.

Impact:   A remote user can create a file that, when loaded by the target user, will execute arbitrary code on the target user's system.
Solution:   Red Hat has issued a fix.

The Red Hat advisory is available at:

https://rhn.redhat.com/errata/RHSA-2012-0011.html

Vendor URL:  www.adobe.com/support/security/bulletins/apsb11-30.html (Links to External Site)
Cause:   Access control error
Underlying OS:  Linux (Red Hat Enterprise)
Underlying OS Comments:  4, 5, 6

Message History:   This archive entry is a follow-up to the message listed below.
Dec 16 2011 Adobe Acrobat/Reader PRC Memory Corruption Error Lets Remote Users Execute Arbitrary Code



 Source Message Contents

Subject:  [RHSA-2012:0011-01] Critical: acroread security update

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Critical: acroread security update
Advisory ID:       RHSA-2012:0011-01
Product:           Red Hat Enterprise Linux Extras
Advisory URL:      https://rhn.redhat.com/errata/RHSA-2012-0011.html
Issue date:        2012-01-10
CVE Names:         CVE-2011-2462 CVE-2011-4369 
=====================================================================

1. Summary:

Updated acroread packages that fix two security issues are now available
for Red Hat Enterprise Linux 4 Extras and Red Hat Enterprise Linux 5 and 6
Supplementary.

The Red Hat Security Response Team has rated this update as having critical
security impact. Common Vulnerability Scoring System (CVSS) base scores,
which give detailed severity ratings, are available for each vulnerability
from the CVE links in the References section.

2. Relevant releases/architectures:

Red Hat Desktop version 4 Extras - i386, x86_64
Red Hat Enterprise Linux AS version 4 Extras - i386, x86_64
Red Hat Enterprise Linux Desktop Supplementary (v. 5) - i386, x86_64
Red Hat Enterprise Linux Desktop Supplementary (v. 6) - i386, x86_64
Red Hat Enterprise Linux ES version 4 Extras - i386, x86_64
Red Hat Enterprise Linux Server Supplementary (v. 5) - i386, x86_64
Red Hat Enterprise Linux Server Supplementary (v. 6) - i386, x86_64
Red Hat Enterprise Linux WS version 4 Extras - i386, x86_64
Red Hat Enterprise Linux Workstation Supplementary (v. 6) - i386, x86_64

3. Description:

Adobe Reader allows users to view and print documents in Portable Document
Format (PDF).

This update fixes two security flaws in Adobe Reader. These flaws are
detailed on the Adobe security page APSB11-30, listed in the References
section. A specially-crafted PDF file could cause Adobe Reader to crash or,
potentially, execute arbitrary code as the user running Adobe Reader when
opened. (CVE-2011-2462, CVE-2011-4369)

All Adobe Reader users should install these updated packages. They contain
Adobe Reader version 9.4.7, which is not vulnerable to these issues. All
running instances of Adobe Reader must be restarted for the update to take
effect.

4. Solution:

Before applying this update, make sure all previously-released errata
relevant to your system have been applied.

This update is available via the Red Hat Network. Details on how to
use the Red Hat Network to apply this update are available at
https://access.redhat.com/kb/docs/DOC-11259

5. Bugs fixed (http://bugzilla.redhat.com/):

760908 - CVE-2011-2462 acroread: U3D memory corruption vulnerability (APSB11-30)
768517 - CVE-2011-4369 acroread: unspecified vulnerability in PRC component (APSB11-30)

6. Package List:

Red Hat Enterprise Linux AS version 4 Extras:

i386:
acroread-9.4.7-1.el4.i386.rpm
acroread-plugin-9.4.7-1.el4.i386.rpm

x86_64:
acroread-9.4.7-1.el4.i386.rpm

Red Hat Desktop version 4 Extras:

i386:
acroread-9.4.7-1.el4.i386.rpm
acroread-plugin-9.4.7-1.el4.i386.rpm

x86_64:
acroread-9.4.7-1.el4.i386.rpm

Red Hat Enterprise Linux ES version 4 Extras:

i386:
acroread-9.4.7-1.el4.i386.rpm
acroread-plugin-9.4.7-1.el4.i386.rpm

x86_64:
acroread-9.4.7-1.el4.i386.rpm

Red Hat Enterprise Linux WS version 4 Extras:

i386:
acroread-9.4.7-1.el4.i386.rpm
acroread-plugin-9.4.7-1.el4.i386.rpm

x86_64:
acroread-9.4.7-1.el4.i386.rpm

Red Hat Enterprise Linux Desktop Supplementary (v. 5):

i386:
acroread-9.4.7-1.el5.i386.rpm
acroread-plugin-9.4.7-1.el5.i386.rpm

x86_64:
acroread-9.4.7-1.el5.i386.rpm
acroread-plugin-9.4.7-1.el5.i386.rpm

Red Hat Enterprise Linux Server Supplementary (v. 5):

i386:
acroread-9.4.7-1.el5.i386.rpm
acroread-plugin-9.4.7-1.el5.i386.rpm

x86_64:
acroread-9.4.7-1.el5.i386.rpm
acroread-plugin-9.4.7-1.el5.i386.rpm

Red Hat Enterprise Linux Desktop Supplementary (v. 6):

i386:
acroread-9.4.7-1.el6.i686.rpm
acroread-plugin-9.4.7-1.el6.i686.rpm

x86_64:
acroread-9.4.7-1.el6.i686.rpm
acroread-plugin-9.4.7-1.el6.i686.rpm

Red Hat Enterprise Linux Server Supplementary (v. 6):

i386:
acroread-9.4.7-1.el6.i686.rpm
acroread-plugin-9.4.7-1.el6.i686.rpm

x86_64:
acroread-9.4.7-1.el6.i686.rpm
acroread-plugin-9.4.7-1.el6.i686.rpm

Red Hat Enterprise Linux Workstation Supplementary (v. 6):

i386:
acroread-9.4.7-1.el6.i686.rpm
acroread-plugin-9.4.7-1.el6.i686.rpm

x86_64:
acroread-9.4.7-1.el6.i686.rpm
acroread-plugin-9.4.7-1.el6.i686.rpm

These packages are GPG signed by Red Hat for security.  Our key and 
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/#package

7. References:

https://www.redhat.com/security/data/cve/CVE-2011-2462.html
https://www.redhat.com/security/data/cve/CVE-2011-4369.html
https://access.redhat.com/security/updates/classification/#critical
http://www.adobe.com/support/security/bulletins/apsb11-30.html

8. Contact:

The Red Hat security contact is <secalert@redhat.com>.  More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2012 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.4 (GNU/Linux)

iD8DBQFPDMKRXlSAg2UNWIIRAkUtAJ9ecqEovcdC+wLbcLbawdlzoYdkUgCeIs+L
99vY+PhmQPOP5eD6B2J2xto=
=wy7X
-----END PGP SIGNATURE-----


-- 
Enterprise-watch-list mailing list
Enterprise-watch-list@redhat.com
https://www.redhat.com/mailman/listinfo/enterprise-watch-list
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC