SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Oracle Java SE Vendors:   Sun
(Red Hat Issues Fix) Oracle Java Runtime Environment (JRE) Multiple Flaws Let Remote Users Execute Arbitrary Code and Deny Service
SecurityTracker Alert ID:  1026489
SecurityTracker URL:  http://securitytracker.com/id/1026489
CVE Reference:   CVE-2011-3545, CVE-2011-3547, CVE-2011-3548, CVE-2011-3549, CVE-2011-3552, CVE-2011-3556, CVE-2011-3557, CVE-2011-3560   (Links to External Site)
Date:  Jan 9 2012
Impact:   Denial of service via network, Disclosure of system information, Disclosure of user information, Execution of arbitrary code via network, Modification of system information, Modification of user information, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): JDK and JRE 7; JDK and JRE 6 Update 27 and prior; JDK and JRE 5.0 Update 31 and prior; SDK and JRE 1.4.2_33 and prior
Description:   Multiple vulnerabilities were reported in Java Runtime Environment (JRE). A remote user can execute arbitrary code on the target system. A remote user can cause denial of service conditions.

A remote user can create a specially crafted Java applet or Java Web Start application that, when loaded by the target user, will access or modify data on the target user's system or execute arbitrary code on the target user's system. The code will run with the privileges of the target user.

A remote user can also cause denial of service conditions.

The following researchers reported these and other Oracle vulnerabilities:

Adam Barth; axtaxt via Tipping Point's Zero Day Initiative; Eric Rescorla; Juliano Rizzo; Michael Schierl via Tipping Point; Neal Poole; Roee Hay of IBM Rational Application Security Research Group; Sami Koivu via Tipping Point's Zero Day Initiative; Thai Duong; and Yair Amit of IBM Rational Application Security Research Group.

Impact:   A remote user can create a Java applet or Java Web Start application that, when loaded by the target user, will access or modify data or execute arbitrary code on the target user's system.

A remote user can cause denial of service conditions on the target system.

Solution:   Red Hat has issued a fix for java-1.4.2-ibm for CVE-2011-3545, CVE-2011-3547, CVE-2011-3548, CVE-2011-3549, CVE-2011-3552, CVE-2011-3556, CVE-2011-3557, and CVE-2011-3560.

The Red Hat advisory is available at:

https://rhn.redhat.com/errata/RHSA-2012-0006.html

Vendor URL:  www.oracle.com/technetwork/topics/security/javacpuoct2011-443431.html (Links to External Site)
Cause:   Not specified
Underlying OS:  Linux (Red Hat Enterprise)
Underlying OS Comments:  4, 5

Message History:   This archive entry is a follow-up to the message listed below.
Oct 19 2011 Oracle Java Runtime Environment (JRE) Multiple Flaws Let Remote Users Execute Arbitrary Code and Deny Service



 Source Message Contents

Subject:  [RHSA-2012:0006-01] Critical: java-1.4.2-ibm security update

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Critical: java-1.4.2-ibm security update
Advisory ID:       RHSA-2012:0006-01
Product:           Red Hat Enterprise Linux Extras
Advisory URL:      https://rhn.redhat.com/errata/RHSA-2012-0006.html
Issue date:        2012-01-09
CVE Names:         CVE-2011-3389 CVE-2011-3545 CVE-2011-3547 
                   CVE-2011-3548 CVE-2011-3549 CVE-2011-3552 
                   CVE-2011-3556 CVE-2011-3557 CVE-2011-3560 
=====================================================================

1. Summary:

Updated java-1.4.2-ibm packages that fix several security issues are now
available for Red Hat Enterprise Linux 4 Extras and Red Hat Enterprise
Linux 5 Supplementary.

The Red Hat Security Response Team has rated this update as having critical
security impact. Common Vulnerability Scoring System (CVSS) base scores,
which give detailed severity ratings, are available for each vulnerability
from the CVE links in the References section.

2. Relevant releases/architectures:

Red Hat Desktop version 4 Extras - i386, x86_64
Red Hat Enterprise Linux AS version 4 Extras - i386, ia64, ppc, s390, s390x, x86_64
Red Hat Enterprise Linux Desktop Supplementary (v. 5) - i386, x86_64
Red Hat Enterprise Linux ES version 4 Extras - i386, ia64, x86_64
Red Hat Enterprise Linux Server Supplementary (v. 5) - i386, ia64, ppc, s390x, x86_64
Red Hat Enterprise Linux WS version 4 Extras - i386, ia64, x86_64

3. Description:

The IBM Java SE version 1.4.2 release includes the IBM Java 1.4.2 Runtime
Environment and the IBM Java 1.4.2 Software Development Kit.

This update fixes several vulnerabilities in the IBM Java 1.4.2 Runtime
Environment and the IBM Java 1.4.2 Software Development Kit. Detailed
vulnerability descriptions are linked from the IBM "Security alerts" page,
listed in the References section. (CVE-2011-3389, CVE-2011-3545,
CVE-2011-3547, CVE-2011-3548, CVE-2011-3549, CVE-2011-3552, CVE-2011-3556,
CVE-2011-3557, CVE-2011-3560)

All users of java-1.4.2-ibm are advised to upgrade to these updated
packages, which contain the IBM Java 1.4.2 SR13-FP11 release. All running
instances of IBM Java must be restarted for this update to take effect.

4. Solution:

Before applying this update, make sure all previously-released errata
relevant to your system have been applied.

This update is available via the Red Hat Network. Details on how to
use the Red Hat Network to apply this update are available at
https://access.redhat.com/kb/docs/DOC-11259

5. Bugs fixed (http://bugzilla.redhat.com/):

737506 - CVE-2011-3389 HTTPS: block-wise chosen-plaintext attack against SSL/TLS (BEAST)
745379 - CVE-2011-3560 OpenJDK: missing checkSetFactory calls in HttpsURLConnection (JSSE, 7096936)
745387 - CVE-2011-3547 OpenJDK: InputStream skip() information leak (Networking/IO, 7000600)
745397 - CVE-2011-3552 OpenJDK: excessive default UDP socket limit under SecurityManager (Networking, 7032417)
745459 - CVE-2011-3556 OpenJDK: RMI DGC server remote code execution (RMI, 7077466)
745464 - CVE-2011-3557 OpenJDK: RMI registry privileged code execution (RMI, 7083012)
745473 - CVE-2011-3548 OpenJDK: mutable static AWTKeyStroke.ctor (AWT, 7019773)
747191 - CVE-2011-3545 Oracle/IBM JDK: unspecified vulnerability fixed in 6u29 (Sound)
747198 - CVE-2011-3549 Oracle/IBM JDK: unspecified vulnerability fixed in 6u29 (Swing)

6. Package List:

Red Hat Enterprise Linux AS version 4 Extras:

i386:
java-1.4.2-ibm-1.4.2.13.11-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-demo-1.4.2.13.11-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-devel-1.4.2.13.11-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-javacomm-1.4.2.13.11-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-jdbc-1.4.2.13.11-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-plugin-1.4.2.13.11-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-src-1.4.2.13.11-1jpp.1.el4.i386.rpm

ia64:
java-1.4.2-ibm-1.4.2.13.11-1jpp.1.el4.ia64.rpm
java-1.4.2-ibm-demo-1.4.2.13.11-1jpp.1.el4.ia64.rpm
java-1.4.2-ibm-devel-1.4.2.13.11-1jpp.1.el4.ia64.rpm
java-1.4.2-ibm-src-1.4.2.13.11-1jpp.1.el4.ia64.rpm

ppc:
java-1.4.2-ibm-1.4.2.13.11-1jpp.1.el4.ppc.rpm
java-1.4.2-ibm-1.4.2.13.11-1jpp.1.el4.ppc64.rpm
java-1.4.2-ibm-demo-1.4.2.13.11-1jpp.1.el4.ppc.rpm
java-1.4.2-ibm-demo-1.4.2.13.11-1jpp.1.el4.ppc64.rpm
java-1.4.2-ibm-devel-1.4.2.13.11-1jpp.1.el4.ppc.rpm
java-1.4.2-ibm-devel-1.4.2.13.11-1jpp.1.el4.ppc64.rpm
java-1.4.2-ibm-javacomm-1.4.2.13.11-1jpp.1.el4.ppc.rpm
java-1.4.2-ibm-javacomm-1.4.2.13.11-1jpp.1.el4.ppc64.rpm
java-1.4.2-ibm-jdbc-1.4.2.13.11-1jpp.1.el4.ppc.rpm
java-1.4.2-ibm-src-1.4.2.13.11-1jpp.1.el4.ppc.rpm
java-1.4.2-ibm-src-1.4.2.13.11-1jpp.1.el4.ppc64.rpm

s390:
java-1.4.2-ibm-1.4.2.13.11-1jpp.1.el4.s390.rpm
java-1.4.2-ibm-demo-1.4.2.13.11-1jpp.1.el4.s390.rpm
java-1.4.2-ibm-devel-1.4.2.13.11-1jpp.1.el4.s390.rpm
java-1.4.2-ibm-jdbc-1.4.2.13.11-1jpp.1.el4.s390.rpm
java-1.4.2-ibm-src-1.4.2.13.11-1jpp.1.el4.s390.rpm

s390x:
java-1.4.2-ibm-1.4.2.13.11-1jpp.1.el4.s390x.rpm
java-1.4.2-ibm-demo-1.4.2.13.11-1jpp.1.el4.s390x.rpm
java-1.4.2-ibm-devel-1.4.2.13.11-1jpp.1.el4.s390x.rpm
java-1.4.2-ibm-src-1.4.2.13.11-1jpp.1.el4.s390x.rpm

x86_64:
java-1.4.2-ibm-1.4.2.13.11-1jpp.1.el4.x86_64.rpm
java-1.4.2-ibm-demo-1.4.2.13.11-1jpp.1.el4.x86_64.rpm
java-1.4.2-ibm-devel-1.4.2.13.11-1jpp.1.el4.x86_64.rpm
java-1.4.2-ibm-javacomm-1.4.2.13.11-1jpp.1.el4.x86_64.rpm
java-1.4.2-ibm-src-1.4.2.13.11-1jpp.1.el4.x86_64.rpm

Red Hat Desktop version 4 Extras:

i386:
java-1.4.2-ibm-1.4.2.13.11-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-demo-1.4.2.13.11-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-devel-1.4.2.13.11-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-javacomm-1.4.2.13.11-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-jdbc-1.4.2.13.11-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-plugin-1.4.2.13.11-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-src-1.4.2.13.11-1jpp.1.el4.i386.rpm

x86_64:
java-1.4.2-ibm-1.4.2.13.11-1jpp.1.el4.x86_64.rpm
java-1.4.2-ibm-demo-1.4.2.13.11-1jpp.1.el4.x86_64.rpm
java-1.4.2-ibm-devel-1.4.2.13.11-1jpp.1.el4.x86_64.rpm
java-1.4.2-ibm-javacomm-1.4.2.13.11-1jpp.1.el4.x86_64.rpm
java-1.4.2-ibm-src-1.4.2.13.11-1jpp.1.el4.x86_64.rpm

Red Hat Enterprise Linux ES version 4 Extras:

i386:
java-1.4.2-ibm-1.4.2.13.11-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-demo-1.4.2.13.11-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-devel-1.4.2.13.11-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-javacomm-1.4.2.13.11-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-jdbc-1.4.2.13.11-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-plugin-1.4.2.13.11-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-src-1.4.2.13.11-1jpp.1.el4.i386.rpm

ia64:
java-1.4.2-ibm-1.4.2.13.11-1jpp.1.el4.ia64.rpm
java-1.4.2-ibm-demo-1.4.2.13.11-1jpp.1.el4.ia64.rpm
java-1.4.2-ibm-devel-1.4.2.13.11-1jpp.1.el4.ia64.rpm
java-1.4.2-ibm-src-1.4.2.13.11-1jpp.1.el4.ia64.rpm

x86_64:
java-1.4.2-ibm-1.4.2.13.11-1jpp.1.el4.x86_64.rpm
java-1.4.2-ibm-demo-1.4.2.13.11-1jpp.1.el4.x86_64.rpm
java-1.4.2-ibm-devel-1.4.2.13.11-1jpp.1.el4.x86_64.rpm
java-1.4.2-ibm-javacomm-1.4.2.13.11-1jpp.1.el4.x86_64.rpm
java-1.4.2-ibm-src-1.4.2.13.11-1jpp.1.el4.x86_64.rpm

Red Hat Enterprise Linux WS version 4 Extras:

i386:
java-1.4.2-ibm-1.4.2.13.11-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-demo-1.4.2.13.11-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-devel-1.4.2.13.11-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-javacomm-1.4.2.13.11-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-jdbc-1.4.2.13.11-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-plugin-1.4.2.13.11-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-src-1.4.2.13.11-1jpp.1.el4.i386.rpm

ia64:
java-1.4.2-ibm-1.4.2.13.11-1jpp.1.el4.ia64.rpm
java-1.4.2-ibm-demo-1.4.2.13.11-1jpp.1.el4.ia64.rpm
java-1.4.2-ibm-devel-1.4.2.13.11-1jpp.1.el4.ia64.rpm
java-1.4.2-ibm-src-1.4.2.13.11-1jpp.1.el4.ia64.rpm

x86_64:
java-1.4.2-ibm-1.4.2.13.11-1jpp.1.el4.x86_64.rpm
java-1.4.2-ibm-demo-1.4.2.13.11-1jpp.1.el4.x86_64.rpm
java-1.4.2-ibm-devel-1.4.2.13.11-1jpp.1.el4.x86_64.rpm
java-1.4.2-ibm-javacomm-1.4.2.13.11-1jpp.1.el4.x86_64.rpm
java-1.4.2-ibm-src-1.4.2.13.11-1jpp.1.el4.x86_64.rpm

Red Hat Enterprise Linux Desktop Supplementary (v. 5):

i386:
java-1.4.2-ibm-1.4.2.13.11-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-demo-1.4.2.13.11-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-devel-1.4.2.13.11-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-javacomm-1.4.2.13.11-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-jdbc-1.4.2.13.11-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-plugin-1.4.2.13.11-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-src-1.4.2.13.11-1jpp.1.el5.i386.rpm

x86_64:
java-1.4.2-ibm-1.4.2.13.11-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-1.4.2.13.11-1jpp.1.el5.x86_64.rpm
java-1.4.2-ibm-demo-1.4.2.13.11-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-demo-1.4.2.13.11-1jpp.1.el5.x86_64.rpm
java-1.4.2-ibm-devel-1.4.2.13.11-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-devel-1.4.2.13.11-1jpp.1.el5.x86_64.rpm
java-1.4.2-ibm-javacomm-1.4.2.13.11-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-javacomm-1.4.2.13.11-1jpp.1.el5.x86_64.rpm
java-1.4.2-ibm-jdbc-1.4.2.13.11-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-plugin-1.4.2.13.11-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-src-1.4.2.13.11-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-src-1.4.2.13.11-1jpp.1.el5.x86_64.rpm

Red Hat Enterprise Linux Server Supplementary (v. 5):

i386:
java-1.4.2-ibm-1.4.2.13.11-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-demo-1.4.2.13.11-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-devel-1.4.2.13.11-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-javacomm-1.4.2.13.11-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-jdbc-1.4.2.13.11-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-plugin-1.4.2.13.11-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-src-1.4.2.13.11-1jpp.1.el5.i386.rpm

ia64:
java-1.4.2-ibm-1.4.2.13.11-1jpp.1.el5.ia64.rpm
java-1.4.2-ibm-demo-1.4.2.13.11-1jpp.1.el5.ia64.rpm
java-1.4.2-ibm-devel-1.4.2.13.11-1jpp.1.el5.ia64.rpm
java-1.4.2-ibm-src-1.4.2.13.11-1jpp.1.el5.ia64.rpm

ppc:
java-1.4.2-ibm-1.4.2.13.11-1jpp.1.el5.ppc.rpm
java-1.4.2-ibm-1.4.2.13.11-1jpp.1.el5.ppc64.rpm
java-1.4.2-ibm-demo-1.4.2.13.11-1jpp.1.el5.ppc.rpm
java-1.4.2-ibm-demo-1.4.2.13.11-1jpp.1.el5.ppc64.rpm
java-1.4.2-ibm-devel-1.4.2.13.11-1jpp.1.el5.ppc.rpm
java-1.4.2-ibm-devel-1.4.2.13.11-1jpp.1.el5.ppc64.rpm
java-1.4.2-ibm-javacomm-1.4.2.13.11-1jpp.1.el5.ppc.rpm
java-1.4.2-ibm-javacomm-1.4.2.13.11-1jpp.1.el5.ppc64.rpm
java-1.4.2-ibm-jdbc-1.4.2.13.11-1jpp.1.el5.ppc.rpm
java-1.4.2-ibm-src-1.4.2.13.11-1jpp.1.el5.ppc.rpm
java-1.4.2-ibm-src-1.4.2.13.11-1jpp.1.el5.ppc64.rpm

s390x:
java-1.4.2-ibm-1.4.2.13.11-1jpp.1.el5.s390.rpm
java-1.4.2-ibm-1.4.2.13.11-1jpp.1.el5.s390x.rpm
java-1.4.2-ibm-demo-1.4.2.13.11-1jpp.1.el5.s390.rpm
java-1.4.2-ibm-demo-1.4.2.13.11-1jpp.1.el5.s390x.rpm
java-1.4.2-ibm-devel-1.4.2.13.11-1jpp.1.el5.s390.rpm
java-1.4.2-ibm-devel-1.4.2.13.11-1jpp.1.el5.s390x.rpm
java-1.4.2-ibm-jdbc-1.4.2.13.11-1jpp.1.el5.s390.rpm
java-1.4.2-ibm-src-1.4.2.13.11-1jpp.1.el5.s390.rpm
java-1.4.2-ibm-src-1.4.2.13.11-1jpp.1.el5.s390x.rpm

x86_64:
java-1.4.2-ibm-1.4.2.13.11-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-1.4.2.13.11-1jpp.1.el5.x86_64.rpm
java-1.4.2-ibm-demo-1.4.2.13.11-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-demo-1.4.2.13.11-1jpp.1.el5.x86_64.rpm
java-1.4.2-ibm-devel-1.4.2.13.11-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-devel-1.4.2.13.11-1jpp.1.el5.x86_64.rpm
java-1.4.2-ibm-javacomm-1.4.2.13.11-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-javacomm-1.4.2.13.11-1jpp.1.el5.x86_64.rpm
java-1.4.2-ibm-jdbc-1.4.2.13.11-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-plugin-1.4.2.13.11-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-src-1.4.2.13.11-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-src-1.4.2.13.11-1jpp.1.el5.x86_64.rpm

These packages are GPG signed by Red Hat for security.  Our key and 
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/#package

7. References:

https://www.redhat.com/security/data/cve/CVE-2011-3389.html
https://www.redhat.com/security/data/cve/CVE-2011-3545.html
https://www.redhat.com/security/data/cve/CVE-2011-3547.html
https://www.redhat.com/security/data/cve/CVE-2011-3548.html
https://www.redhat.com/security/data/cve/CVE-2011-3549.html
https://www.redhat.com/security/data/cve/CVE-2011-3552.html
https://www.redhat.com/security/data/cve/CVE-2011-3556.html
https://www.redhat.com/security/data/cve/CVE-2011-3557.html
https://www.redhat.com/security/data/cve/CVE-2011-3560.html
https://access.redhat.com/security/updates/classification/#critical
http://www.ibm.com/developerworks/java/jdk/alerts/

8. Contact:

The Red Hat security contact is <secalert@redhat.com>.  More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2012 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.4 (GNU/Linux)

iD8DBQFPC0nZXlSAg2UNWIIRAv1RAKCl92qrTYYU1hbGCfxx4pg/qqVM2gCcDbOP
1GEavw104zEMlVmzCOrcfx4=
=j7JJ
-----END PGP SIGNATURE-----


--
RHSA-announce mailing list
RHSA-announce@redhat.com
https://www.redhat.com/mailman/listinfo/rhsa-announce
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC