SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Web Server/CGI)  >   Fujitsu Interstage Vendors:   Fujitsu
(Fujitsu Issues Fix for Interstage HTTP Server) Apache APR Library apr_fnmatch() Flaw Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1026258
SecurityTracker URL:  http://securitytracker.com/id/1026258
CVE Reference:   CVE-2011-0419   (Links to External Site)
Date:  Oct 31 2011
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   A vulnerability was reported in Apache. A remote user can cause denial of service conditions. Interstage HTTP Server is affected.

A remote user can send specially crafted data to trigger recursive string matching in the Apache Portable Runtime library's apr_fnmatch() function and cause the target service to consume excessive CPU resources on the target system.

Systems with mod_autoindex enabled and with a directory indexed by mod_autoindex and containing files with sufficiently long names are affected.

Maksymilian Arciemowicz reported this vulnerability.

Impact:   A remote user can cause excessive CPU consumption on the target system.
Solution:   Fujitsu has issued a fix for Interstage HTTP Server.

The Fujitsu advisory is available at:

http://www.fujitsu.com/global/support/software/security/products-f/interstage-201104e.html

Cause:   State error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   This archive entry is a follow-up to the message listed below.
May 12 2011 Apache APR Library apr_fnmatch() Flaw Lets Remote Users Execute Arbitrary Code



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC