SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   FreeType Vendors:   freetype.org
FreeType Type 1 Font Processing Flaw Lets Remote Users Deny Service
SecurityTracker Alert ID:  1026237
SecurityTracker URL:  http://securitytracker.com/id/1026237
CVE Reference:   CVE-2011-3256   (Links to External Site)
Date:  Oct 24 2011
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 2.4.7
Description:   A vulnerability was reported in FreeType. A remote user can cause arbitrary code to be executed on the target user's system.

A remote user can create a specially crafted Type 1 font file that, when loaded by the target user, will execute arbitrary code on the target system. The code will run with the privileges of the target user or application.

[Editor's note: This vulnerability was previously reported by Apple as affecting Apple iOS in Alert ID 1026180.]

Impact:   A remote user can create a file that, when loaded by the target user, will execute arbitrary code on the target user's system.
Solution:   The vendor has issued a fix (2.4.7).

The vendor's advisory is available at:

http://sourceforge.net/projects/freetype/files/freetype2/2.4.7/README/view

Vendor URL:  www.freetype.org/ (Links to External Site)
Cause:   Not specified
Underlying OS:  Linux (Any), UNIX (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Oct 25 2011 (Red Hat Issues Fix) FreeType Type 1 Font Processing Flaw Lets Remote Users Deny Service
Red Hat has issued a fix for Red Hat Enterprise Linux 4, 5, and 6.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC