SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   OS (Other)  >   HPE NonStop Server Vendors:   HPE
(HP Issues Fix for HP NonStop Servers) Oracle Java Runtime Environment (JRE) Double Precision Conversion Error Lets Remote Users Deny Service
SecurityTracker Alert ID:  1025093
SecurityTracker URL:  http://securitytracker.com/id/1025093
CVE Reference:   CVE-2010-4476   (Links to External Site)
Date:  Feb 18 2011
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   A vulnerability was reported in Java Runtime Environment (JRE). A remote user can cause denial of service conditions. NonStop Java on HP NonStop Servers is affected.

A remote user can trigger a flaw in the conversion of "2.2250738585072012e-308" to a double precision binary floating-point number to cause the target JRE engine to enter an infinite loop.

The following versions are affected:

JDK and JRE 6 Update 23 and prior
JDK and JRE 5.0 Update 27 and prior
SDK and JRE 1.4.2_29 and prior

Konstantin Preiber reported this vulnerability.

Impact:   A remote user can cause the target service to hang.
Solution:   HP has issued a fix for NonStop Java on HP NonStop Servers (use HP FPUpdater tool), available at:

https://h20392.www2.hp.com/portal/swdepot/displayProductInfo.do?productNumber=HPUXFPUPDATER

The HP advisory is available at:

https://www11.itrc.hp.com/service/cki/docDisplay.do?docId=emr_na-c02720715

Cause:   State error

Message History:   This archive entry is a follow-up to the message listed below.
Feb 10 2011 Oracle Java Runtime Environment (JRE) Double Precision Conversion Error Lets Remote Users Deny Service



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC