SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Forum/Board/Portal)  >   WordPress Vendors:   wordpress.org
WordPress XML-RPC Interface Bug Lets Remote Authenticated Users Modify Posts
SecurityTracker Alert ID:  1024842
SecurityTracker URL:  http://securitytracker.com/id/1024842
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  Dec 9 2010
Impact:   Modification of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 3.0.3
Description:   A vulnerability was reported in WordPress. A remote authenticated user can make unauthorized modifications to posts.

A remote authenticated user with Author or Contributor privileges can exploit a flaw in the XML-RPC remote publishing interface to improperly edit, publish, or delete posts.

Impact:   A remote authenticated user with Author or Contributor privileges can improperly edit, publish, or delete posts.
Solution:   The vendor has issued a fix (3.0.3).

The vendor's advisory is available at:

http://codex.wordpress.org/Version_3.0.3

Vendor URL:  codex.wordpress.org/Version_3.0.3 (Links to External Site)
Cause:   Access control error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC