SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Perl Vendors:   Wall, Larry
(Sun Issues Fix) Perl Safe Module (Safe::reval and Safe::rdo) Can Be Bypassed
SecurityTracker Alert ID:  1024792
SecurityTracker URL:  http://securitytracker.com/id/1024792
CVE Reference:   CVE-2010-1168   (Links to External Site)
Date:  Nov 28 2010
Impact:   User access via local system
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 5.10.0 and prior
Description:   A vulnerability was reported in Perl. A local user can bypass certain safe module restrictions.

Implicitly called methods (e.g., DESTROY, AUTOLOAD) are not properly restricted by Safe::reval and Safe::rdo. A local user can run a specially crafted Perl script within a Safe compartment to execute those methods without restriction.

Safe.pm version 2.24 and prior versions are affected.

Nick Cleaton reported this vulnerability.

Impact:   A local user can bypass certain safe module restrictions.
Solution:   Sun has issued a fix.

The Sun advisory is available at:

http://blogs.sun.com/security/entry/cve_2010_1168_vulnerability_in

Vendor URL:  cpan.org/ (Links to External Site)
Cause:   Access control error
Underlying OS:  UNIX (Solaris - SunOS)
Underlying OS Comments:  10

Message History:   This archive entry is a follow-up to the message listed below.
Jun 7 2010 Perl Safe Module (Safe::reval and Safe::rdo) Can Be Bypassed



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC