SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   PHP Vendors:   PHP Group
PHP Use After Free in 'ext/imap/php_imap.c' Lets Remote Users Deny Service
SecurityTracker Alert ID:  1024761
SecurityTracker URL:  http://securitytracker.com/id/1024761
CVE Reference:   CVE-2010-4150   (Links to External Site)
Updated:  Jul 18 2015
Original Entry Date:  Nov 22 2010
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 5.2.14, 5.3.3; possibly others
Description:   A vulnerability was reported in PHP. A remote user can cause denial of service conditions.

A remote user can send specially crafted IMAP user name or password data to trigger a double free memory error in 'ext/imap/php_imap.c' and cause the target service to crash.

It may be possible to execute arbitrary code. However, code execution was not confirmed.

Impact:   A remote user can cause denial of service conditions.
Solution:   The vendor has issued a source code fix, available at:

http://svn.php.net/viewvc?view=revision&revision=305032

Vendor URL:  www.php.net/ (Links to External Site)
Cause:   Access control error, State error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC