SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Device (Embedded Server/Appliance)  >   LANDesk Management Suite Vendors:   LANDesk Software
LANDesk Management Gateway Input Validation Error Lets Remote Authenticated Administrators Injection Operating System Commands
SecurityTracker Alert ID:  1024728
SecurityTracker URL:  http://securitytracker.com/id/1024728
CVE Reference:   CVE-2010-2892   (Links to External Site)
Date:  Nov 11 2010
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  Exploit Included:  Yes  
Version(s): 4.0-1.48, 4.2-1.8
Description:   A vulnerability was reported in LANDesk Management Gateway. A remote authenticated user can execute arbitrary operating system commands on the target system.

A remote authenticated user can send a specially crafted request to inject operating system commands on the target system. The commands will run with 'gsbadmin' user privileges. This can be exploited to shutdown the firewall or load arbitrary kernel modules.

The vendor was notified on October 18, 2010.

Aureliano Calvo from Core Security Technologies reported this vulnerability.

Impact:   A remote authenticated administrator can execute arbitrary operating system commands on the target system.
Solution:   The vendor has issued a fix (LANDesk Management Gateway 4.0 GSBWEB v1.62, LANDesk Management Gateway 4.2 GSBWEB v1.62).

The vendor's advisory is available at:

http://community.landesk.com/support/docs/DOC-21767

Vendor URL:  community.landesk.com/support/docs/DOC-21767 (Links to External Site)
Cause:   Input validation error

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC