SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Adobe Acrobat/Reader Vendors:   Adobe Systems Incorporated
Adobe Reader and Acrobat Multiple Flaws Let Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1024511
SecurityTracker URL:  http://securitytracker.com/id/1024511
CVE Reference:   CVE-2010-2887, CVE-2010-2888, CVE-2010-2889, CVE-2010-2890, CVE-2010-3619, CVE-2010-3620, CVE-2010-3621, CVE-2010-3622, CVE-2010-3623, CVE-2010-3624, CVE-2010-3625, CVE-2010-3626, CVE-2010-3627, CVE-2010-3628, CVE-2010-3629, CVE-2010-3630, CVE-2010-3631, CVE-2010-3632, CVE-2010-3656, CVE-2010-3657, CVE-2010-3658   (Links to External Site)
Date:  Oct 6 2010
Impact:   Denial of service via network, Execution of arbitrary code via network, User access via local system, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 9.3.4 and prior versions
Description:   Multiple vulnerabilities were reported in Adobe Acrobat and Adobe Reader. A remote user can cause arbitrary code to be executed on the target user's system. A remote user can cause denial of service conditions. A local user can gain elevated privileges.

A remote user can create specially crafted content that, when loaded by the target user, will execute arbitrary code on the target system. The code will run with the privileges of the target user.

On Linux-based systems, a local user can gain elevated privileges [CVE-2010-2887].

On Windows-based systems, input validation errors can cause code execution [CVE-2010-2888].

A font-parsing input validation flaw can cause code execution [CVE-2010-2889, CVE-2010-3626].

A memory corruption flaw can cause code execution [CVE-2010-2890, CVE-2010-3619, CVE-2010-3621, CVE-2010-3622, CVE-2010-3623, CVE-2010-3628, CVE-2010-3632, CVE-2010-3658].

An image-parsing input validation flaw can cause code execution [CVE-2010-3620, CVE-2010-3624, CVE-2010-3629].

A prefix protocol handler flaw can cause code execution [CVE-2010-3625].

An input validation flaw can cause code execution [CVE-2010-3627].

A denial of service flaw may potentially lead to code execution [CVE-2010-3630].

On Mac-based systems, an array-indexing flaw can cause code execution [CVE-2010-3631].

Denial of service conditions may occur [CVE-2010-3656, CVE-2010-3657].

Red Hat Security Response Team, Tavis Ormandy of the Google Security Team, Sebastian Apelt via TippingPoint's Zero Day Initiative, James Quirk of Los Alamos, New Mexico, Felipe Andres Manzano via the iSIGHT Partners Global Vulnerability Partnership, Billy Rios from the Google Security Team, Ricardo Narvaja of Core Security Technologies, Bing Liu of Fortinet's FortiGuard Labs, Will Dormann of CERT, Brett Gervasoni of Sense of Security, Knud Erik Hojgaard of nSense Vulnerability Research Team, and an anonymous reporter via TippingPoint's Zero Day Initiative reported these vulnerabilities.

Impact:   A remote user can create content that, when loaded by the target user, will execute arbitrary code or cause denial of service conditions on the target user's system.

A local user can gain elevated privileges on Linux-based systems.

Solution:   The vendor has issued a fix (8.2.5, 9.4).

Adobe Reader 9.4 for UNIX will be available by October 21, 2010.

The vendor's advisory is available at:

http://www.adobe.com/support/security/bulletins/apsb10-21.html

Vendor URL:  www.adobe.com/support/security/bulletins/apsb10-21.html (Links to External Site)
Cause:   Access control error, Boundary error, Input validation error
Underlying OS:  Linux (Any), UNIX (macOS/OS X), UNIX (Solaris - SunOS), Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC