(Red Hat Issues Advisory) Adobe Acrobat and Adobe Reader Flaws Lets Remote Users Execute Arbitrary Code and Deny Service
SecurityTracker Alert ID: 1023483|
SecurityTracker URL: http://securitytracker.com/id/1023483
CVE-2009-3953, CVE-2009-3954, CVE-2009-3955, CVE-2009-3956, CVE-2009-3959
(Links to External Site)
Date: Jan 20 2010
Denial of service via network, Execution of arbitrary code via network, User access via network|
Vendor Confirmed: Yes |
Version(s): 9.2 and prior versions|
Several vulnerabilities were reported in Adobe Acrobat and Adobe Reader. A remote user can cause arbitrary code to be executed on the target user's system. A remote user can cause denial of service conditions.|
A remote user can create a specially crafted PDF file that, when loaded by the target user, will execute arbitrary code on the target system. The code will run with the privileges of the target user.
An array boundary issue in U3D support can cause code execution [CVE-2009-3953].
A DLL-loading vulnerability in 3D can cause code execution [CVE-2009-3954].
A memory corruption vulnerability can cause code execution [CVE-2009-3955].
A script injection vulnerability exists [CVE-2009-3956].
A null-pointer dereference vulnerability can cause denial of service conditions [CVE-2009-3957].
A buffer overflow vulnerability in the Download Manager can cause code execution [CVE-2009-3958].
An integer overflow vulnerability in U3D support can cause code execution [CVE-2009-3959].
Secunia, Greg MacManus of iSIGHT Partners Labs, Code Audit Labs via iDefense, stratsec, Didier Stevens, Will Dormann of CERT, and Nicolas Joly of VUPEN Vulnerability Research Team reported these vulnerabilities.
A remote user can create a PDF file that, when loaded by the target user, will execute arbitrary code on the target user's system or cause the target user's reader to crash.|
Red Hat has issued an advisory for CVE-2009-3953, CVE-2009-3954, CVE-2009-3955, CVE-2009-3956, and CVE-2009-3959, warning that the acroread client should not be used and should be uninstalled.|
The vendor's advisory is available at:
Vendor URL: www.adobe.com/support/security/bulletins/apsb10-02.html (Links to External Site)
Access control error, Boundary error, Input validation error|
|Underlying OS: Linux (Red Hat Enterprise)|
|Underlying OS Comments: 3|
This archive entry is a follow-up to the message listed below.|
Source Message Contents
Subject: [RHSA-2010:0060-01] Critical: acroread security update|
-----BEGIN PGP SIGNED MESSAGE-----
Red Hat Security Advisory
Synopsis: Critical: acroread security update
Advisory ID: RHSA-2010:0060-01
Product: Red Hat Enterprise Linux Extras
Advisory URL: https://rhn.redhat.com/errata/RHSA-2010-0060.html
Issue date: 2010-01-20
CVE Names: CVE-2009-3953 CVE-2009-3954 CVE-2009-3955
CVE-2009-3956 CVE-2009-3959 CVE-2009-4324
The acroread packages as shipped in Red Hat Enterprise Linux 3 Extras
contain security flaws and should not be used.
This update has been rated as having critical security impact by the Red
Hat Security Response Team.
2. Relevant releases/architectures:
Red Hat Desktop version 3 Extras - i386
Red Hat Enterprise Linux AS version 3 Extras - i386
Red Hat Enterprise Linux ES version 3 Extras - i386
Red Hat Enterprise Linux WS version 3 Extras - i386
Adobe Reader allows users to view and print documents in Portable Document
Adobe Reader 8.1.7 is vulnerable to critical security flaws and should no
longer be used. A specially-crafted PDF file could cause Adobe Reader to
crash or, potentially, execute arbitrary code as the user running Adobe
Reader when opened. (CVE-2009-4324, CVE-2009-3953, CVE-2009-3954,
CVE-2009-3955, CVE-2009-3959, CVE-2009-3956)
Adobe have discontinued support for Adobe Reader 8 for Linux. Adobe Reader
9 for Linux is not compatible with Red Hat Enterprise Linux 3. An
alternative PDF file viewer available in Red Hat Enterprise Linux 3 is
This update removes the acroread packages due to their known security
Before applying this update, make sure that all previously-released
errata relevant to your system have been applied.
This update is available via Red Hat Network. Details on how to use
the Red Hat Network to apply this update are available at
5. Bugs fixed (http://bugzilla.redhat.com/):
554293 - CVE-2009-3953 CVE-2009-3954 CVE-2009-3955 CVE-2009-3959 acroread: multiple code execution flaws (APSB10-02)
554296 - CVE-2009-3956 acroread: script injection vulnerability (APSB10-02)
6. Package List:
Red Hat Enterprise Linux AS version 3 Extras:
Red Hat Desktop version 3 Extras:
Red Hat Enterprise Linux ES version 3 Extras:
Red Hat Enterprise Linux WS version 3 Extras:
These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
The Red Hat security contact is <firstname.lastname@example.org>. More contact
details at https://www.redhat.com/security/team/contact/
Copyright 2010 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.4 (GNU/Linux)
-----END PGP SIGNATURE-----
Enterprise-watch-list mailing list