SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Adobe Acrobat/Reader Vendors:   Adobe Systems Incorporated
(Red Hat Issues Fix) Adobe Acrobat and Adobe Reader Flaws Lets Remote Users Execute Arbitrary Code and Deny Service
SecurityTracker Alert ID:  1023020
SecurityTracker URL:  http://securitytracker.com/id/1023020
CVE Reference:   CVE-2009-2564, CVE-2009-2979, CVE-2009-2980, CVE-2009-2981, CVE-2009-2982, CVE-2009-2983, CVE-2009-2984, CVE-2009-2985, CVE-2009-2986, CVE-2009-2987, CVE-2009-2988, CVE-2009-2989, CVE-2009-2990, CVE-2009-2991, CVE-2009-2992, CVE-2009-2993, CVE-2009-2994, CVE-2009-2995, CVE-2009-2996, CVE-2009-2997, CVE-2009-2998, CVE-2009-3431, CVE-2009-3458, CVE-2009-3460, CVE-2009-3461, CVE-2009-3462   (Links to External Site)
Date:  Oct 14 2009
Impact:   Execution of arbitrary code via network, User access via local system, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 9.1.3 and prior versions; also 7.1 prior to 7.1.4, 8.1 prior to 8.1.7
Description:   Multiple vulnerabilities were reported in Adobe Acrobat and Adobe Reader. A remote user can cause arbitrary code to be executed on the target user's system. A remote user can cause denial of service conditions on the target user's system. A local user can gain elevated privileges.

A remote user can create a specially crafted file that, when loaded by the target user, will execute arbitrary code on the target system. The code will run with the privileges of the target user.

The following vulnerabilities may permit code execution:

- memory corruption [CVE-2009-2985]
- heap overflows [CVE-2009-2986]
- invalid array index flaw [CVE-2009-2990], fixed in the Adobe Reader and Acrobat 9.2 and 8.1.7 updates
- Mozilla plug-in flaw [CVE-2009-2991], fixed in the Adobe Reader and Acrobat 8.1.7 updates
- input validation flaws [CVE-2009-2993]
- buffer overflow [CVE-2009-2994]
- heap overflow [CVE-2009-2997]
- input validation [CVE-2009-2998]
- input validation [CVE-2009-3458]
- memory corruption in Acrobat but not Adobe Reader [CVE-2009-3460], fixed in the Acrobat 9.2 and 8.1.7 updates
- integer overflow in Acrobat but not Adobe Reader [CVE-2009-2989], fixed in the Acrobat 9.2 and 8.1.7 updates

The following vulnerabilities permit denial of service and some may permit code execution:

- memory corruption [CVE-2009-2983], fixed in the Adobe Reader and Acrobat 9.2 and 8.1.7 updates
- integer overflow [CVE-2009-2980]
- memory corruption [CVE-2009-2996]
- format bug when running in Debug mode on UNIX [CVE-2009-3462]
- image decoder flaw in Acrobat but not Adobe Reader [CVE-2009-2984], fixed in the Acrobat 9.2 update.
- input validation that may allow a bypass of Trust Manager restrictions [CVE-2009-2981].
- an unspecified flaw in the file extension security controls that affects Acrobat versions 9.x [CVE-2009-3461].
- a certificate flaw [CVE-2009-2982], fixed in the Adobe Reader and Acrobat 9.2 and 8.1.7 updates
- a stack overflow [CVE-2009-3431], fixed in the Adobe Reader and Acrobat 9.2 and 8.1.7 updates
- a flaw in XMP-XML entity expansion [CVE-2009-2979], fixed in the Adobe Reader and Acrobat 9.2 and 8.1.7 updates
- a flaw in the ActiveX control, affecting Windows-based systems [CVE-2009-2987].
- input validation [CVE-2009-2988]
- input validation in the ActiveX control, affecting Windows-based systems [CVE-2009-2992], fixed in the Adobe Reader and Acrobat 9.2 and 8.1.7 updates.
- integer overflow in Acrobat but not Adobe Reader [CVE-2009-2995].
- unspecified flaw in a third party web download product that may allow a local user to gain elevated privileges [CVE-2009-2564].

The following researchers reported these vulnerabilities:

Didier Stevens (CVE-2009-2979); Drew Yao of Apple Product Security (CVE-2009-2980); Stefano Di Paola of Minded Security (CVE-2009-2981); Guillaume Delugr and Fr d ric Raynal of SOGETI ESEC (CVE-2009-2982, CVE-2009-3461, CVE-2009-3462); SkyLined of Google Inc. (CVE-2009-2983); Tavis Ormandy, Google Security Team (CVE-2009-2984); An anonymous researcher via TippingPoint (CVE-2009-2985); Will Dormann, CERT (CVE-2009-2986); Zhenhua Liu and Xiaopeng Zhang of Fortinet's FortiGuard Global Security Research Team (CVE-2009-2987, CVE-2009-2988, CVE-2009-2996); Tielei Wang from ICST-ERCIS (Engineering Research Center of Info Security, Institute of Computer Science & Technology, Peking University / China) (CVE-2009-2989, CVE-2009-2995); Dionysus Blazakis via iDefense (CVE-2009-2990); Elazar Broad via iDefense (CVE-2009-2991); David Soldera of Next Generation Security Software (CVE-2009-2992); IOActive (CVE-2009-2993); Felipe Andres Manzano via iSIGHT Partners (CVE-2009-2994); Nicolas Joly of VUPEN Security (CVE-2009-2997, CVE-2009-2998, CVE-2009-3458); Haifei Li of Fortinet's FortiGuard Global Security Research Team (CVE-2009-3460).

Impact:   A remote user can create a file that, when loaded by the target user, will execute arbitrary code or cause denial of service conditions on the target user's system.

A local user may be able to obtain elevated privileges.

Solution:   Red Hat has released a fix.

The Red Hat advisory is available at:

https://rhn.redhat.com/errata/RHSA-2009-1499.html

Vendor URL:  www.adobe.com/support/security/bulletins/apsb09-15.html (Links to External Site)
Cause:   Access control error, Boundary error, Not specified
Underlying OS:  Linux (Red Hat Enterprise)
Underlying OS Comments:  3, 4, 5

Message History:   This archive entry is a follow-up to the message listed below.
Oct 13 2009 Adobe Acrobat and Adobe Reader Flaws Lets Remote Users Execute Arbitrary Code and Deny Service



 Source Message Contents

Subject:  [RHSA-2009:1499-01] Critical: acroread security update


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Critical: acroread security update
Advisory ID:       RHSA-2009:1499-01
Product:           Red Hat Enterprise Linux Extras
Advisory URL:      https://rhn.redhat.com/errata/RHSA-2009-1499.html
Issue date:        2009-10-14
CVE Names:         CVE-2009-2979 CVE-2009-2980 CVE-2009-2981 
                   CVE-2009-2983 CVE-2009-2985 CVE-2009-2986 
                   CVE-2009-2988 CVE-2009-2990 CVE-2009-2991 
                   CVE-2009-2993 CVE-2009-2994 CVE-2009-2996 
                   CVE-2009-2997 CVE-2009-2998 CVE-2009-3431 
                   CVE-2009-3458 CVE-2009-3459 CVE-2009-3462 
=====================================================================

1. Summary:

Updated acroread packages that fix multiple security issues are now
available for Red Hat Enterprise Linux 3 Extras, Red Hat Enterprise Linux 4
Extras, and Red Hat Enterprise Linux 5 Supplementary.

This update has been rated as having critical security impact by the Red
Hat Security Response Team.

2. Relevant releases/architectures:

RHEL Desktop Supplementary (v. 5 client) - i386, x86_64
RHEL Supplementary (v. 5 server) - i386, x86_64
Red Hat Desktop version 3 Extras - i386, x86_64
Red Hat Desktop version 4 Extras - i386, x86_64
Red Hat Enterprise Linux AS version 3 Extras - i386, x86_64
Red Hat Enterprise Linux AS version 4 Extras - i386, x86_64
Red Hat Enterprise Linux ES version 3 Extras - i386, x86_64
Red Hat Enterprise Linux ES version 4 Extras - i386, x86_64
Red Hat Enterprise Linux WS version 3 Extras - i386, x86_64
Red Hat Enterprise Linux WS version 4 Extras - i386, x86_64

3. Description:

Adobe Reader allows users to view and print documents in Portable Document
Format (PDF).

Multiple flaws were discovered in Adobe Reader. A specially-crafted PDF
file could cause Adobe Reader to crash or, potentially, execute arbitrary
code as the user running Adobe Reader when opened. (CVE-2009-2980,
CVE-2009-2983, CVE-2009-2985, CVE-2009-2986, CVE-2009-2990, CVE-2009-2991,
CVE-2009-2993, CVE-2009-2994, CVE-2009-2996, CVE-2009-2997, CVE-2009-2998,
CVE-2009-3458, CVE-2009-3459, CVE-2009-3462)

Multiple flaws were discovered in Adobe Reader. A specially-crafted PDF
file could cause Adobe Reader to crash when opened. (CVE-2009-2979,
CVE-2009-2988, CVE-2009-3431)

An input validation flaw was found in Adobe Reader. Opening a
specially-crafted PDF file could lead to a Trust Manager restrictions
bypass. (CVE-2009-2981)

All Adobe Reader users should install these updated packages. They contain
Adobe Reader version 8.1.7, which is not vulnerable to these issues. All
running instances of Adobe Reader must be restarted for the update to take
effect.

4. Solution:

Before applying this update, make sure that all previously-released
errata relevant to your system have been applied.

This update is available via Red Hat Network.  Details on how to use
the Red Hat Network to apply this update are available at
http://kbase.redhat.com/faq/docs/DOC-11259

5. Bugs fixed (http://bugzilla.redhat.com/):

528071 - CVE-2009-3459 acroread: heap overflow fix in version 8.1.7 (APSB09-15)
528659 - acroread: Multiple arbitrary code execution fixes in 8.1.7 (APSB09-15)
528665 - CVE-2009-2979 CVE-2009-2988 CVE-2009-3431 acroread: Multiple DoS fixes in 8.1.7 (APSB09-15)
528666 - CVE-2009-2981 acroread: Trust Manager restrictions bypass fixed in 8.1.7 (APSB09-15)

6. Package List:

Red Hat Enterprise Linux AS version 3 Extras:

i386:
acroread-8.1.7-1.i386.rpm
acroread-plugin-8.1.7-1.i386.rpm

x86_64:
acroread-8.1.7-1.i386.rpm

Red Hat Desktop version 3 Extras:

i386:
acroread-8.1.7-1.i386.rpm
acroread-plugin-8.1.7-1.i386.rpm

x86_64:
acroread-8.1.7-1.i386.rpm

Red Hat Enterprise Linux ES version 3 Extras:

i386:
acroread-8.1.7-1.i386.rpm
acroread-plugin-8.1.7-1.i386.rpm

x86_64:
acroread-8.1.7-1.i386.rpm

Red Hat Enterprise Linux WS version 3 Extras:

i386:
acroread-8.1.7-1.i386.rpm
acroread-plugin-8.1.7-1.i386.rpm

x86_64:
acroread-8.1.7-1.i386.rpm

Red Hat Enterprise Linux AS version 4 Extras:

i386:
acroread-8.1.7-1.el4.i386.rpm
acroread-plugin-8.1.7-1.el4.i386.rpm

x86_64:
acroread-8.1.7-1.el4.i386.rpm

Red Hat Desktop version 4 Extras:

i386:
acroread-8.1.7-1.el4.i386.rpm
acroread-plugin-8.1.7-1.el4.i386.rpm

x86_64:
acroread-8.1.7-1.el4.i386.rpm

Red Hat Enterprise Linux ES version 4 Extras:

i386:
acroread-8.1.7-1.el4.i386.rpm
acroread-plugin-8.1.7-1.el4.i386.rpm

x86_64:
acroread-8.1.7-1.el4.i386.rpm

Red Hat Enterprise Linux WS version 4 Extras:

i386:
acroread-8.1.7-1.el4.i386.rpm
acroread-plugin-8.1.7-1.el4.i386.rpm

x86_64:
acroread-8.1.7-1.el4.i386.rpm

RHEL Desktop Supplementary (v. 5 client):

i386:
acroread-8.1.7-1.el5.i386.rpm
acroread-plugin-8.1.7-1.el5.i386.rpm

x86_64:
acroread-8.1.7-1.el5.i386.rpm
acroread-plugin-8.1.7-1.el5.i386.rpm

RHEL Supplementary (v. 5 server):

i386:
acroread-8.1.7-1.el5.i386.rpm
acroread-plugin-8.1.7-1.el5.i386.rpm

x86_64:
acroread-8.1.7-1.el5.i386.rpm
acroread-plugin-8.1.7-1.el5.i386.rpm

These packages are GPG signed by Red Hat for security.  Our key and 
details on how to verify the signature are available from
https://www.redhat.com/security/team/key/#package

7. References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-2979
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-2980
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-2981
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-2983
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-2985
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-2986
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-2988
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-2990
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-2991
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-2993
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-2994
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-2996
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-2997
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-2998
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-3431
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-3458
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-3459
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-3462
http://www.redhat.com/security/updates/classification/#critical
http://www.adobe.com/support/security/bulletins/apsb09-15.html

8. Contact:

The Red Hat security contact is <secalert@redhat.com>.  More contact
details at https://www.redhat.com/security/team/contact/

Copyright 2009 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.4 (GNU/Linux)

iD8DBQFK1fq0XlSAg2UNWIIRApi5AKCbRP0OxKoT4Dr5Wihfd9Q5nAfxTACgsZwk
UrxseotbW5ASovfZQjGlrPc=
=2LHp
-----END PGP SIGNATURE-----


-- 
Enterprise-watch-list mailing list
Enterprise-watch-list@redhat.com
https://www.redhat.com/mailman/listinfo/enterprise-watch-list

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC