SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Web Browser)  >   Google Chrome Vendors:   Google
Google Chrome Buffer Overflow in Processing HTTP Responses Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1022429
SecurityTracker URL:  http://securitytracker.com/id/1022429
CVE Reference:   CVE-2009-2121   (Links to External Site)
Date:  Jun 23 2009
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 2.0.172.33
Description:   A vulnerability was reported in Google Chrome. A remote user can cause arbitrary code to be executed on the target user's system.

A remote server can return a specially crafted HTTP response to trigger a buffer overflow and execute arbitrary code on the target system. The code will run with the privileges of the target user running the chrome application.

The vulnerability resides in the browser kernel.

The Google Chrome security team reported this vulnerability.

Impact:   A remote server can execute arbitrary code on the target system.
Solution:   The vendor has issued a fix (2.0.172.33).

The vendor's advisory is available at:

http://googlechromereleases.blogspot.com/2009/06/stable-beta-update-security-fix.html

Vendor URL:  www.google.com/ (Links to External Site)
Cause:   Boundary error
Underlying OS:  Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC