SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Oracle Java SE Vendors:   Sun
(Red Hat Issues Fix) Sun Java Runtime Environment 'Calendar.readObject' Bug Lets Remote Applets Gain Elevated Privileges
SecurityTracker Alert ID:  1022193
SecurityTracker URL:  http://securitytracker.com/id/1022193
CVE Reference:   CVE-2008-5353   (Links to External Site)
Date:  May 7 2009
Impact:   Disclosure of system information, Disclosure of user information, Execution of arbitrary code via network, Modification of user information, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): JDK and JRE 6 Update 10 and prior; JDK and JRE 5.0 Update 16 and prior; SDK and JRE 1.4.2_18 and prior
Description:   A vulnerability was reported in Java Runtime Environment (JRE). A remote user can read/write files and execute applications on the target user's system.

A remote user can create a specially crafted applet or application that, when loaded by the target user, will exploit a flaw in the processing of calendar objects and will read and write local files or execute applications on the target system with the privileges of the target user.

Sami Koivu reported this vulnerability.

Impact:   A remote user can create an applet or application that, when loaded by the target user, will read/write files and execute applications on the target user's system with the privileges of the target user.
Solution:   Red Hat has released a fix.

The Red Hat advisory is available at:

https://rhn.redhat.com/errata/RHSA-2009-0466.html

Vendor URL:  sunsolve.sun.com/search/document.do?assetkey=1-66-244991-1 (Links to External Site)
Cause:   Access control error
Underlying OS:  Linux (Red Hat Enterprise)
Underlying OS Comments:  4, 5

Message History:   This archive entry is a follow-up to the message listed below.
Dec 5 2008 Sun Java Runtime Environment 'Calendar.readObject' Bug Lets Remote Applets Gain Elevated Privileges



 Source Message Contents

Subject:  [RHSA-2009:0466-02] Low: java-1.5.0-ibm security update


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Low: java-1.5.0-ibm security update
Advisory ID:       RHSA-2009:0466-02
Product:           Red Hat Network Satellite Server
Advisory URL:      https://rhn.redhat.com/errata/RHSA-2009-0466.html
Issue date:        2009-05-07
CVE Names:         CVE-2008-3103 CVE-2008-5345 CVE-2008-5346 
                   CVE-2008-5348 CVE-2008-5349 CVE-2008-5350 
                   CVE-2008-5351 CVE-2008-5352 CVE-2008-5353 
                   CVE-2008-5354 CVE-2008-5356 CVE-2008-5357 
                   CVE-2008-5359 CVE-2008-5360 
=====================================================================

1. Summary:

Updated java-1.5.0-ibm packages that fix several security issues are now
available for Red Hat Network Satellite Server.

This update has been rated as having low security impact by the Red Hat
Security Response Team.

2. Relevant releases/architectures:

Red Hat Network Satellite Server 5.2 (RHEL v.4 AS) - i386, s390, s390x, x86_64
Red Hat Network Satellite Server 5.2 (RHEL v.5) - i386, s390x, x86_64

3. Description:

This update corrects several security vulnerabilities in the IBM Java 2
Runtime Environment and the IBM Java 2 Software Development Kit, shipped as
part of Red Hat Network Satellite Server. In a typical operating
environment, these are of low security risk as the runtime is not used on
untrusted applets.

Several vulnerabilities were discovered in the IBM Java 2 Runtime
Environment and the IBM Java 2 Software Development Kit. These
vulnerabilities are summarized on the IBM "Security alerts" page listed in
the References section. (CVE-2008-3103, CVE-2008-5345, CVE-2008-5346,
CVE-2008-5348, CVE-2008-5349, CVE-2008-5350, CVE-2008-5351, CVE-2008-5352,
CVE-2008-5353, CVE-2008-5354, CVE-2008-5356, CVE-2008-5357, CVE-2008-5359,
CVE-2008-5360)

All users of java-1.5.0-ibm are advised to upgrade to these updated
packages, containing the IBM 1.5.0 SR9 Java release. All running instances
of IBM Java must be restarted for the update to take effect.

4. Solution:

Before applying this update, make sure that all previously-released
errata relevant to your system have been applied.

This update is available via Red Hat Network. Details on how to use
the Red Hat Network to apply this update are available at
http://kbase.redhat.com/faq/docs/DOC-11259

5. Bugs fixed (http://bugzilla.redhat.com/):

452659 - CVE-2008-3103 OpenJDK JMX allows illegal operations with local monitoring (6332953)
472201 - CVE-2008-5350 OpenJDK allows to list files within the user home directory (6484091)
472206 - CVE-2008-5349 OpenJDK RSA public key length denial-of-service (6497740)
472209 - CVE-2008-5348 OpenJDK Denial-Of-Service in kerberos authentication (6588160)
472211 - CVE-2008-5360 OpenJDK temporary files have guessable file names (6721753)
472212 - CVE-2008-5359 OpenJDK Buffer overflow in image processing (6726779)
472213 - CVE-2008-5351 OpenJDK UTF-8 decoder accepts non-shortest form sequences (4486841)
472218 - CVE-2008-5356 OpenJDK Font processing vulnerability (6733336)
472224 - CVE-2008-5353 OpenJDK calendar object deserialization allows privilege escalation (6734167)
472228 - CVE-2008-5354 OpenJDK Privilege escalation in command line applications (6733959)
472231 - CVE-2008-5357 OpenJDK Truetype Font processing vulnerability (6751322)
472233 - CVE-2008-5352 OpenJDK Jar200 Decompression buffer overflow (6755943)
474793 - CVE-2008-5345 JRE allows unauthorized file access and connections to localhost
474794 - CVE-2008-5346 JRE allows unauthorized memory read access via a crafted ZIP file

6. Package List:

Red Hat Network Satellite Server 5.2 (RHEL v.4 AS):

Source:
ftp://updates.redhat.com/enterprise/4AS/en/RHNSAT/SRPMS/java-1.5.0-ibm-1.5.0.9-1jpp.4.el4.src.rpm

i386:
java-1.5.0-ibm-1.5.0.9-1jpp.4.el4.i386.rpm
java-1.5.0-ibm-devel-1.5.0.9-1jpp.4.el4.i386.rpm

s390:
java-1.5.0-ibm-1.5.0.9-1jpp.4.el4.s390.rpm
java-1.5.0-ibm-devel-1.5.0.9-1jpp.4.el4.s390.rpm

s390x:
java-1.5.0-ibm-1.5.0.9-1jpp.4.el4.s390x.rpm
java-1.5.0-ibm-devel-1.5.0.9-1jpp.4.el4.s390x.rpm

x86_64:
java-1.5.0-ibm-1.5.0.9-1jpp.4.el4.x86_64.rpm
java-1.5.0-ibm-devel-1.5.0.9-1jpp.4.el4.x86_64.rpm

Red Hat Network Satellite Server 5.2 (RHEL v.5):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/RHNSAT/SRPMS/java-1.5.0-ibm-1.5.0.9-1jpp.2.el5.src.rpm

i386:
java-1.5.0-ibm-1.5.0.9-1jpp.2.el5.i386.rpm
java-1.5.0-ibm-devel-1.5.0.9-1jpp.2.el5.i386.rpm

s390x:
java-1.5.0-ibm-1.5.0.9-1jpp.2.el5.s390x.rpm
java-1.5.0-ibm-devel-1.5.0.9-1jpp.2.el5.s390x.rpm

x86_64:
java-1.5.0-ibm-1.5.0.9-1jpp.2.el5.x86_64.rpm
java-1.5.0-ibm-devel-1.5.0.9-1jpp.2.el5.x86_64.rpm

These packages are GPG signed by Red Hat for security.  Our key and 
details on how to verify the signature are available from
https://www.redhat.com/security/team/key/#package

7. References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-3103
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-5345
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-5346
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-5348
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-5349
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-5350
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-5351
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-5352
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-5353
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-5354
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-5356
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-5357
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-5359
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-5360
http://www.redhat.com/security/updates/classification/#low
http://www-128.ibm.com/developerworks/java/jdk/alerts/

8. Contact:

The Red Hat security contact is <secalert@redhat.com>.  More contact
details at https://www.redhat.com/security/team/contact/

Copyright 2009 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.4 (GNU/Linux)

iD8DBQFKAtMcXlSAg2UNWIIRAl6EAJ99DtsdtYeHykAhQoAkv1qLLoF+9QCePMsv
kp5UiiT4h617oUeqbxbYIVQ=
=xYtN
-----END PGP SIGNATURE-----


--
RHSA-announce mailing list
RHSA-announce@redhat.com
https://www.redhat.com/mailman/listinfo/rhsa-announce

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC