SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Web Browser)  >   Opera Vendors:   Opera Software
Opera History Search Bug Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1021128
SecurityTracker URL:  http://securitytracker.com/id/1021128
CVE Reference:   CVE-2008-4794   (Links to External Site)
Updated:  Aug 14 2009
Original Entry Date:  Nov 3 2008
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 9.62
Description:   A vulnerability was reported in Opera. A remote user can cause arbitrary code to be executed on the target user's system.

Certain parameters passed to the History Search may not be properly sanitized. As a result, a remote user can cause scripting code to be executed with elevated privileges. This can be exploited to modify the browser's configuration, when allows arbitrary code to be executed.

Impact:   A remote user can cause arbitrary code to be executed on the target user's system.
Solution:   The vendor has issued a fixed version (9.62).

The vendor's advisory is available at:

http://www.opera.com/support/search/view/906/

Vendor URL:  www.opera.com/support/search/view/906/ (Links to External Site)
Cause:   Access control error
Underlying OS:  Linux (Any), UNIX (FreeBSD), UNIX (macOS/OS X), UNIX (Solaris - SunOS), Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC