SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Web Server/CGI)  >   Red Hat JBoss Vendors:   JBoss Group, Red Hat
(Red Hat Issues Fix) JBoss Input Validation Hole in JavaServer Faces Permits Cross-Site Scripting Attacks and Access Control Bug in Status Servlet Lets Remote Users Obtain Information
SecurityTracker Alert ID:  1020629
SecurityTracker URL:  http://securitytracker.com/id/1020629
CVE Reference:   CVE-2008-1285, CVE-2008-3273   (Links to External Site)
Date:  Aug 6 2008
Impact:   Disclosure of authentication information, Disclosure of system information, Disclosure of user information, Execution of arbitrary code via network, Modification of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   Two vulnerabilities were reported in JBoss. A remote user can conduct cross-site scripting attacks. A remote user can determine information about deployed web contexts.

The JavaServer Faces (JSF) component does not properly filter HTML code from user-supplied input before displaying the input [CVE-2008-1285]. A remote user can create a specially crafted URL that, when loaded by a target user, will cause arbitrary scripting code to be executed by the target user's browser. The code will originate from the site running the JBoss software and will run in the security context of that site. As a result, the code will be able to access the target user's cookies (including authentication cookies), if any, associated with the site, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

A remote user can access the status servlet to obtain information about deployed web contexts [CVE-2008-3273].

Impact:   A remote user can access the target user's cookies (including authentication cookies), if any, associated with the site running the JBoss software, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

A remote user can determine details about deployed web contexts on the target system.

Solution:   Red Hat has released a fix (4.3.0CP01).

The Red Hat advisory is available at:

https://rhn.redhat.com/errata/RHSA-2008-0828.html

Vendor URL:  rhn.redhat.com/errata/RHSA-2008-0825.html (Links to External Site)
Cause:   Access control error, Input validation error
Underlying OS:  Linux (Red Hat Enterprise)
Underlying OS Comments:  5

Message History:   This archive entry is a follow-up to the message listed below.
Aug 5 2008 JBoss Input Validation Hole in JavaServer Faces Permits Cross-Site Scripting Attacks and Access Control Bug in Status Servlet Lets Remote Users Obtain Information



 Source Message Contents

Subject:  [RHSA-2008:0828-02] Moderate: JBoss Enterprise Application Platform


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Moderate: JBoss Enterprise Application Platform 4.3.0CP01 security update
Advisory ID:       RHSA-2008:0828-02
Product:           JBoss Enterprise Application Platform
Advisory URL:      https://rhn.redhat.com/errata/RHSA-2008-0828.html
Issue date:        2008-08-05
CVE Names:         CVE-2008-1285 CVE-2008-3273 
=====================================================================

1. Summary:

Updated JBoss Enterprise Application Platform (JBoss EAP) packages that fix
various security issues are now available for Red Hat Enterprise Linux 5.

This update has been rated as having moderate security impact by the Red
Hat Security Response Team.

2. Relevant releases/architectures:

JBoss Enterprise Application Platform 4.3.0 for RHEL 5 Server - noarch

3. Description:

JBoss EAP is a middleware platform for Java 2 Platform, Enterprise Edition
(J2EE) applications.

This release of JBoss EAP for Red Hat Enterprise Linux 5 contains the JBoss
Application Server and JBoss Seam. This release serves as a replacement to
JBoss EAP 4.3.0.GA, and fixes the following security issues:

The JavaServer Faces (JSF) component was vulnerable to multiple cross-site
scripting (XSS) vulnerabilities. An attacker could use these flaws to
inject arbitrary web script or HTML. (CVE-2008-1285)

Unauthenticated users were able to access the status servlet, which could
allow remote attackers to acquire details about deployed web contexts.
(CVE-2008-3273)

These updated packages include bug fixes and enhancements which are not
listed here. For a full list, refer to the JBoss EAP 4.3.0.CP01 release
notes, linked to in the "References" section of this advisory.

Warning: before applying this update, please back up the JBoss EAP
"server/[configuration]/deploy/" directory, and any customized
configuration files.

All users of JBoss EAP on Red Hat Enterprise Linux 5 are advised to upgrade
to these updated packages, which resolve these issues.

4. Solution:

Before applying this update, make sure that all previously-released
errata relevant to your system have been applied.

This update is available via Red Hat Network.  Details on how to use
the Red Hat Network to apply this update are available at
http://kbase.redhat.com/faq/FAQ_58_10188

5. Bugs fixed (http://bugzilla.redhat.com/):

437082 - CVE-2008-1285 Cross-site scripting (XSS) vulnerability in Sun Java Server Faces
457757 - CVE-2008-3273 JBossEAP status servlet info leak

6. Package List:

JBoss Enterprise Application Platform 4.3.0 for RHEL 5 Server:

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/JBEAP/SRPMS/asm-1.5.3-1jpp.ep1.2.el5.src.rpm
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/JBEAP/SRPMS/cglib-2.1.3-2jpp.ep1.6.el5.src.rpm
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/JBEAP/SRPMS/concurrent-1.3.4-8jpp.ep1.6.el5.1.src.rpm
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/JBEAP/SRPMS/glassfish-jaf-1.1.0-0jpp.ep1.11.el5.1.src.rpm
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/JBEAP/SRPMS/glassfish-javamail-1.4.0-0jpp.ep1.9.el5.src.rpm
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/JBEAP/SRPMS/glassfish-jsf-1.2_08-0jpp.ep1.2.el5.src.rpm
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/JBEAP/SRPMS/hibernate3-3.2.4-1.SP1_CP03.0jpp.ep1.1.el5.src.rpm
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/JBEAP/SRPMS/hibernate3-annotations-3.2.1-1.patch02.1jpp.ep1.3.el5.1.src.rpm
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/JBEAP/SRPMS/hibernate3-entitymanager-3.2.1-1jpp.ep1.7.el5.src.rpm
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/JBEAP/SRPMS/jboss-aop-1.5.5-1.CP01.0jpp.ep1.1.el5.src.rpm
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/JBEAP/SRPMS/jboss-cache-1.4.1-4.SP9.1jpp.ep1.1.el5.src.rpm
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/JBEAP/SRPMS/jboss-messaging-1.4.0-1.SP3_CP02.0jpp.ep1.6.el5.src.rpm
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/JBEAP/SRPMS/jboss-remoting-2.2.2-3.SP7.0jpp.ep1.3.el5.src.rpm
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/JBEAP/SRPMS/jboss-seam-1.2.1-3.JBPAPP_4_3_0_GA.ep1.5.el5.1.src.rpm
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/JBEAP/SRPMS/jbossas-4.3.0-2.GA_CP01.ep1.6.el5.1.src.rpm
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/JBEAP/SRPMS/jbossts-4.2.3-1.SP5_CP01.1jpp.ep1.1.el5.src.rpm
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/JBEAP/SRPMS/jbossws-2.0.1-2.SP2_CP01.0jpp.ep1.2.el5.src.rpm
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/JBEAP/SRPMS/jbossxb-1.0.0-2.SP1.0jpp.ep1.2.el5.1.src.rpm
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/JBEAP/SRPMS/jcommon-1.0.12-1jpp.ep1.3.el5.src.rpm
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/JBEAP/SRPMS/jfreechart-1.0.9-1jpp.ep1.3.el5.1.src.rpm
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/JBEAP/SRPMS/jgroups-2.4.2-1.GA_CP01.0jpp.ep1.1.el5.src.rpm
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/JBEAP/SRPMS/rh-eap-docs-4.3.0-2.GA_CP01.ep1.4.el5.src.rpm

noarch:
asm-1.5.3-1jpp.ep1.2.el5.noarch.rpm
cglib-2.1.3-2jpp.ep1.6.el5.noarch.rpm
concurrent-1.3.4-8jpp.ep1.6.el5.1.noarch.rpm
glassfish-jaf-1.1.0-0jpp.ep1.11.el5.1.noarch.rpm
glassfish-javamail-1.4.0-0jpp.ep1.9.el5.noarch.rpm
glassfish-jsf-1.2_08-0jpp.ep1.2.el5.noarch.rpm
hibernate3-annotations-3.2.1-1.patch02.1jpp.ep1.3.el5.1.noarch.rpm
hibernate3-annotations-javadoc-3.2.1-1.patch02.1jpp.ep1.3.el5.1.noarch.rpm
hibernate3-entitymanager-3.2.1-1jpp.ep1.7.el5.noarch.rpm
hibernate3-entitymanager-javadoc-3.2.1-1jpp.ep1.7.el5.noarch.rpm
hibernate3-javadoc-3.2.4-1.SP1_CP03.0jpp.ep1.1.el5.noarch.rpm
jboss-aop-1.5.5-1.CP01.0jpp.ep1.1.el5.noarch.rpm
jboss-cache-1.4.1-4.SP9.1jpp.ep1.1.el5.noarch.rpm
jboss-messaging-1.4.0-1.SP3_CP02.0jpp.ep1.6.el5.noarch.rpm
jboss-remoting-2.2.2-3.SP7.0jpp.ep1.3.el5.noarch.rpm
jboss-seam-1.2.1-3.JBPAPP_4_3_0_GA.ep1.5.el5.1.noarch.rpm
jboss-seam-docs-1.2.1-3.JBPAPP_4_3_0_GA.ep1.5.el5.1.noarch.rpm
jbossas-4.3.0-2.GA_CP01.ep1.6.el5.1.noarch.rpm
jbossts-4.2.3-1.SP5_CP01.1jpp.ep1.1.el5.noarch.rpm
jbossws-2.0.1-2.SP2_CP01.0jpp.ep1.2.el5.noarch.rpm
jbossws-native42-2.0.1-2.SP2_CP01.0jpp.ep1.2.el5.noarch.rpm
jbossxb-1.0.0-2.SP1.0jpp.ep1.2.el5.1.noarch.rpm
jcommon-1.0.12-1jpp.ep1.3.el5.noarch.rpm
jfreechart-1.0.9-1jpp.ep1.3.el5.1.noarch.rpm
jgroups-2.4.2-1.GA_CP01.0jpp.ep1.1.el5.noarch.rpm
rh-eap-docs-4.3.0-2.GA_CP01.ep1.4.el5.noarch.rpm

These packages are GPG signed by Red Hat for security.  Our key and 
details on how to verify the signature are available from
https://www.redhat.com/security/team/key/#package

7. References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-1285
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-3273
http://redhat.com/docs/en-US/JBoss_Enterprise_Application_Platform/4.3.0.cp01/html-single/readme/
http://www.redhat.com/security/updates/classification/#moderate

8. Contact:

The Red Hat security contact is <secalert@redhat.com>.  More contact
details at https://www.redhat.com/security/team/contact/

Copyright 2008 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.4 (GNU/Linux)

iD8DBQFImBWyXlSAg2UNWIIRAmS2AJ4o57frRDxToeq2DS5y8ULp6Y4zTQCeKa7l
6Mi9nvmdqDaNNunyCNWVhR0=
=VG9s
-----END PGP SIGNATURE-----


--
RHSA-announce mailing list
RHSA-announce@redhat.com
https://www.redhat.com/mailman/listinfo/rhsa-announce

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC