SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Commerce)  >   VP-ASP Vendors:   Virtual Programming
VP-ASP Input Validation Hole in 'shopcontent.asp' Permits Cross-Site Scripting Attacks
SecurityTracker Alert ID:  1018083
SecurityTracker URL:  http://securitytracker.com/id/1018083
CVE Reference:   CVE-2007-2790   (Links to External Site)
Updated:  May 12 2008
Original Entry Date:  May 18 2007
Impact:   Disclosure of authentication information, Disclosure of user information, Execution of arbitrary code via network, Modification of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  Exploit Included:  Yes  
Version(s): 6.50
Description:   A vulnerability was reported in VP-ASP. A remote user can conduct cross-site scripting attacks.

The 'shopcontent.asp' script does not properly filter HTML code from user-supplied input in the 'type' parameter before displaying the input. A remote user can create a specially crafted URL that, when loaded by a target user, will cause arbitrary scripting code to be executed by the target user's browser. The code will originate from the site running the VP-ASP software and will run in the security context of that site. As a result, the code will be able to access the target user's cookies (including authentication cookies), if any, associated with the site, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

John Martinelli of RedLevel Security discovered this vulnerability.

[Editor's note: In the May 10, 2007 patch description for 'shop$db.asp', the vendor indicates that SQL injection may also be possible.]

Impact:   A remote user can access the target user's cookies (including authentication cookies), if any, associated with the site running the VP-ASP software, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.
Solution:   The vendor issued a patch on May 16, 2007.

The VP-ASP advisory is available at:

http://www.vpasp.com/helpnotes/fixes.asp?version=v650

Vendor URL:  www.vpasp.com/helpnotes/fixes.asp?version=v650 (Links to External Site)
Cause:   Input validation error
Underlying OS:  Windows (Any)

Message History:   None.


 Source Message Contents

Subject:  VP-ASP Shopping Cart 6.50 - Cross-Site Scripting Vulnerability

<!--

VP-ASP Shopping Cart 6.50 - Cross-Site Scripting Vulnerability

A cross-site scripting vulnerability in VP-ASP Shopping Cart 6.50 was discovered. The vendor, VP-ASP, shipped an official patch on
 May 16th, 2007.

Vulnerable Variable: type
Vulnerable File: shopcontent.asp
Vulnerable: VP-ASP Shopping Cart 6.50 (other versions should also be vulnerable)
Google d0rk: intitle:"VP-ASP Shopping Cart 6.50"

John Martinelli
john@martinelli.com

RedLevel Security
http://www.RedLevel.org

May 16th, 2007

!-->

<html>
<head><title>VP-ASP Shopping Cart 6.50 - Cross-Site Scripting Vulnerability</title><body>
<center><br><br>
<font size=4>VP-ASP Shopping Cart 6.50 - Cross-Site Scripting Vulnerability</font><br>
<font size=3>discovered by <a href="http://john-martinelli.com">John Martinelli</a> of <a href="http://redlevel.org">RedLevel Security</a><br><br>
Google d0rk: <a href="http://www.google.com/search?q=intitle%3A%22VP-ASP+Shopping+Cart+6.50%22">intitle:"VP-ASP Shopping Cart 6.50"</a>
</font><br><br><br>

<center>file <b>shopcontent.asp</b> - variable <b>type</b> - method <b>get</b></center><br>
<form action="http://www.target.com/shop/shopcontent.asp" method="get">
<input size=75 name="type" value="<body onload=alert(1)>">
<input type=submit value="Execute XSS Attack" class="button">
</form>
<br><br><br>

</form>
</body></html>

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC